Sort by date - recently updated software

Hi all,

Currently using a crypto hardware wallet (Trezor) that is no longer being recognized by my system (Linux 5.10.34-1 Manjaro XFCE). Up until recently, the wallet worked fine. However now, it’s not being recognized.

I ran software updates through the software manager, so I think maybe something there has effected it.
Admittedly, I’m not sure exactly what installed. I just gave permission and installed all.

Any way that I can view my software/programs list sorted by recently updated?

pamac history does that.

1 Like

Simple. Haha thank you I found it. (Pamac → 3 vertical dots in the top right → View History)

Is there a way to I guess, “roll-back” the installs that I completed 24hrs to their previous versions?

Rolling releases only roll one way. Why do you think you need to “roll-back?”

Where did you install Trezor from? It’s neither in the repos nor the AUR.

Well prior to running the updates in the manager, the wallet was working. I only suspect that perhaps one of those updates (I’m not sure which, there was about 80 of them) is causing the hardware wallet to not be recognized now?

I have this Trezor Bridge installed:

Also, I use Trezor Suite from the web app. I don’t have a program installed for that.

What’s not working exactly? Is there an error message?

So usually, I would connect via the USB cable and log in via pin # on the device. Then, whatever interface I am using to view crypto balances, make transactions, etc (like Trezor Suite) would recognize the device and I can make transactions, etc.

However now, if I do that, and try to access the balance or send money, it’s saying “Connect wallet” or “Connect device”. There’s no error, it’s just not recognizing.

However, when I go into Electrum (a btc wallet) and try to use that for funds, I get this:

No Hardware detected
To trigger a rescan, press ‘Next’.
On Linux, you might have to add a new permission to your udev rules
Debug message
trezor: (error getting device infos)
trezord: acquire/2/null failed with code 400:

Aha. I just saw on Trezor’s changelog the unreleased 2.0.31 version updated libusb, so that could be what fixes it.

Oh, and just to be sure–you did reboot after the update, right?

Ah yes I didn’t think to check the changelog. Thank you very much for your help. I will await their update.

So after the updates in Pamac, I didn’t reboot immediately. I rebooted once I discovered the device wasn’t being recognized (so maybe 4-5hrs later).

It looks like they also support using a web browser, have you tried that?

Yes, I only use the web browser to access the suite. I get the same result (says “Connect device” so it is not recognizing the device).

So I’ve tried the device on another laptop. Works fine. That laptop is running Windows 10.

No issues recognizing and using the device…

Update: Still not working on my Manjaro laptop. I have contacted Trezor support.

I’ve started looking into it a bit myself.

The Trezor Bridge I am using - AUR (en) - trezor-bridge-bin
There should be a process called trezord. However, that isn’t running on my machine, and maybe that means the device isn’t being recognized?

usr/bin and I execute: trezord and it outputs:

2021/05/15 19:33:56 trezord v2.0.30 is starting.
2021/05/15 19:33:56 https: listen tcp bind: address already in use

I go to the task manager and the trezord process is not there.

I also tried: netstat -lptn

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0*               LISTEN      -                   
tcp        0      0*               LISTEN      4200/python3.7    

Any ideas as to why trezord is not executing? I feel if it executes, the device may finally once again be recognized?

Edit2: okay I run htop and I can see /usr/bin/trezord is running. But my device still not recognized. Hmmm, might be another issue then…

LIBUSB_ERROR_ACCESS still seems to be the problem…

Edit3: Fixed it. Managed to run the code from this page: Udev rules - Trezor Wiki
And now the device is recognized and working as it should.
Thanks for the help all (this started just to view install history in Pamac)

Trezor has an appimage - maybe that’ll sort it. Apps:Trezor Suite - Trezor Wiki