Sometimes Everything Slow... Except Mouse?

This problem happens randomly, typically around once a month. Sometimes happens after booting/logging in and others times it will just happen after hours of perfectly fine use. Suddenly everything except the mouse runs at about 1 fps. The mouse still works just fine but when I click to do anything in any applications, or click on the Manjaro menu, bar, etc. There is about a second delay before the action happens and everything “skips” / runs as if it were 1 fps. Some applications launch or run much slower than normal.

In most cases attempting a normal shut down or reboot is either too slow or never completes. It will usually get to the point where it is a black screen with blinking cursor but no further and I need to hard reset.

No idea where to start diagnosing this. Next time it happens I will open OBS and see if it will record what is going on, or use my phone to record so you can see.

Hello @jimbo2150 :wink:

That could be a problem with opengl rendering. Try switching to xrender (software renderer).

I assume your internal one is intel. Then have look at this:

man intel
modinfo i915

Maybe you need to add triple-buffer? Not sure…

I tried man intel and it said that triple buffer should be enabled by default. There is no x11 config file - according to a number of other posts Intel should not need one normally. There was nothing in modinfo i915 about triple buffer either. Is there any way to check that?

After I switched to xrender then back to opengl it happened again. Here is a video of the issue:

You can see the mouse moves around just fine but scrolling is very slow/laggy and opening and scrolling through the menu is very slow & laggy.

Maybe check this thread: Desktop Lag/Stuttering while gaming - #2 by bogdancovaciu

Please check also this file: /etc/profile.d/
Maybe this is needed to add?

echo "export KWIN_TRIPLE_BUFFER=1" | sudo tee /etc/profile.d/

Sorry, I am not an KDE-User. So no idea. But it 100% related to opengl and the gpu.

Doesn’t seem to have worked :slightly_frowning_face:

I looked at the logs after causing it to run slow and outside of a couple odd IRQ issues which seem to be CPU related, nothing appeared to relate to graphics.

Interesting, by default it seems to load a modesetting driver. I forced it to load the Intel driver instead and am not able to get it to run slow when I change compositors.

Can you elaborate those steps you took so that others who face the same problem may be able to self diagnose as well?

Unfortunately after a few hours the system became consistently unstable and there were jagged lines/flickering on external display so I had to revert the changes. Continuing to look for a better solution.

Is this a laptop with a nvidia card? if so check out this

Thanks, and that might be the issue. However, I appear to not be able to do anything about it ATM. The current Nvidia driver appears to have a known bug that it can’t start up discreet GPUs that are idled/powered down. I get error messages in the log about the nvidia driver not being able to initialize the GPU. I tried the nouveau driver as well and it has it’s own issues and for some reason no xrandr provider is available.

So until Nvidia or nouveau provides a working driver, I cannot test that.

The latest stable update combined with a new BIOS update appears to have fixed the Nvidia card not being detected/usable. However, I am still able to make everything slow by switching the render back & forth so I suspect this issue is still possible.