Some windows are in light mode and others in dark mode,

Hi everyone! don’t know if it was because I’ve deleted these packages:

Missing AUR Packages: adwaita-maia firefox-gnome-theme-maia gnome-shell-extension-vertical-overview gnome-system-log libgweather manjaro-dynamic-wallpaper manjaro-firmware manjaro-gnome-tour tracker tracker-miners

But now, some windows are in light mode and others in dark mode, it’s really strange since I had the dark mode enabled (and in case of Gimp it has selected the System Theme and it used to be dark and Manjaro dark colored). Look:

The only thing i did was to aply yay -R and one by one of the missing AUR packages

You’ll have to keep track of packages that got removed or that aren’t compatible with new software anymore. Constantly. Read update announcements, etc. And replace them with new packages, themes and whatnot.

I think you have to install “adw-gnome-something-theme”(?) because adwaita isn’t compatible anymore. At least I think I saw some topics along these lines. Someone who uses GNOME should tell you for sure. Paging @Yochanan. (or you can search)

Your issue has nothing to do with the thread you posted in. That’s considered thread hijacking and is against the Forum Rules. I’ve moved your post to a new thread.

1 Like

In my defense, i didn’t know if it was related or not with what i did in the other post, that’s why i’ve continued it. Anyway, still learning each time i write here, thanks for the patience, and is there any suggestions beside what @zbe wrote? cause definitely have no idea.

Aren’t we all? I learn something new and make a new mistake every day.

Why, what’s wrong with his suggestion?

FYI, It’s adw-gtk-theme which does the Libadwaita magic for legacy applications (aka Gtk 3) using the adw-gtk3 theme. :wink:

Precisely what you answered latter, didn’t know what @zbe meant wiwth “adw-gnome-something-theme” ja…anyway, I’ve tried to install both adw-gtk-theme and adw-gtk3 but it seems that i already have them and still not solved the issue.

PS: not sure if i’m doing something wrong or if that was what i had to do

    ~  LANG=C yay adw-gtk-theme                                 ✔  59s  
2 aur/adw-gtk-theme 1.1-2 (+8 1.31) (Installed)
    LibAdwaita Theme for all GTK3 and GTK4 Apps. NOTE: This is a meta package which uses adw-gtk3 for GTK3 and official LibAdwaita theme for GTK4
1 community/adw-gtk-theme 1.1-1 (21.1 KiB 1.5 KiB) (Installed: 1.1-2)
    LibAdwaita Theme for all GTK3 and GTK4 Apps
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 
 there is nothing to do
    ~  LANG=C yay adw-gtk3                                      ✔  16s  
4 aur/adw-gtk-theme 1.1-2 (+8 1.31) (Installed)
    LibAdwaita Theme for all GTK3 and GTK4 Apps. NOTE: This is a meta package which uses adw-gtk3 for GTK3 and official LibAdwaita theme for GTK4
3 aur/adw-gtk3-git 1.0.r2.a2a0114-1 (+10 0.55) 
    The theme from libadwaita ported to GTK-3
2 aur/adw-gtk3 4.1-1 (+28 7.39) (Installed)
    The theme from libadwaita ported to GTK-3
1 community/adw-gtk3 4.1-1 (112.6 KiB 1.4 MiB) (Installed)
    The theme from libadwaita ported to GTK-3
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 
 there is nothing to do

Did you set Legacy Applications to Adw-dark in Tweaks > Appearance?

These folders should not contain any .css files or assets folders. If there are any, they may be leftover from a previous custom theme you may have installed:

~/.config/gtk-3.0/
~/.config/gtk-4.0/

If you meant this part, then yes, it’s always been in Dark mode

They both had .css files which i’ve erased them, but left the one of bookmarks and noup, still works as the first image, the folders are dark, but the terminal and other apps light.

Unless you do a lot of housekeeping the packages can be found in /var/cache/pacman/pkg/
reinstall adwaita-maia by “cd /var/cache/pacman/pkg/”
then by “sudo pacman -U adwaita-maia-20210130-1-any.pkg.tar.xz”

Check “etc/environment” file and see if QT_QPA_PLATFORMTHEME and QT_STYLE_OVERRIDE is hashed out, if not hash them out, reboot and see if that helps.

Here is what my environment file looks like as i had issues just like you are having, and this seemed to be the only fix that worked for me, other then some apps needed to be set to dark in whatever app’s settings.

> # This file is parsed by pam_env module
> #
> # Syntax: simple "KEY=VAL" pairs on separate lines
> #
> 
> QT_AUTO_SCREEN_SCALE_FACTOR=1
> 
> # QT_QPA_PLATFORMTHEME="gnome"
> 
> # QT_STYLE_OVERRIDE="kvantum"
> 
> # Force to use Xwayland backend
> # QT_QPA_PLATFORM=xcb
> 
> #Not tested: this should disable window decorations
> # QT_WAYLAND_DISABLE_WINDOWDECORATION=1
> 
> EDITOR=/usr/bin/nano

No, I do not. Again, I was referring to the Appearance section of Tweaks.

1 Like

That’s it! thanks @Yochanan !! had to investigate where was that part and it’s from Gnome and not Manjaro, it was empty and it began to work when i’ve selected the Adw-dark.

@oldfrog and @TheReaperUK thanks for the support, didn’t had to try what you shared but I appreciate your answers.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.