Some keys not working for a while after startup

Below my system specs

  Kernel: 6.1.53-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet Desktop: i3 v: 4.20.1-98-ga70b89a7 info: polybar vt: 7
    dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X521IA_M533IA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X521IA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X521IA.300 date: 04/13/2020
  ID-1: BAT0 charge: 32.3 Wh (98.8%) condition: 32.7/50.0 Wh (65.3%)
    power: 5.2 W volts: 11.9 min: 11.9 model: ASUSTeK ASUS Battery type: Li-ion
    serial: N/A status: discharging cycles: 536
  Info: 8-core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64
    type: MCP smt: <unsupported> arch: Zen 2 rev: 1 cache: L1: 512 KiB L2: 4 MiB
    L3: 8 MiB
  Speed (MHz): avg: 1473 high: 2000 min/max: 1400/2000 boost: enabled cores:
    1: 2000 2: 1397 3: 1398 4: 1400 5: 1397 6: 1400 7: 1400 8: 1397
    bogomips: 31958
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5
    pcie: speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 03:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 36.0 C
  Device-2: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-3:3 chip-ID: 13d3:56a2
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0 driver: X:
    loaded: amdgpu dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: LG Display 0x0563 res: 1920x1080
    hz: 60 dpi: 142 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") modes:
    max: 1920x1080 min: 640x480
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.1.53-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.80 status: off with: pipewire-media-session
    status: off
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8821ce v: N/A pcie: speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 3-2:2 chip-ID: 13d3:3530
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 3 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 class-ID: 10c
  Local Storage: total: 476.94 GiB used: 423.66 GiB (88.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: FXV7000Q temp: 19.9 C scheme: GPT
  ID-1: / size: 459.43 GiB used: 423.66 GiB (92.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (rpm): cpu: 0
  Processes: 240 Uptime: 15m wakeups: 2264 Memory: total: 16 GiB note: est.
  available: 15.05 GiB used: 3.19 GiB (21.2%) Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman
  pkgs: 2071 Shell: Zsh v: 5.9 running-in: alacritty inxi: 3.3.30

It’s been a while that some of the keyboard keys are not working (not functionality keys, just ordinary ones as p,',ò,- and up/right arrow). The problem arises at the startup and persists for a while but eventually they work fine. Anyway the amount of time needed to the keys to start working again could be long.

I cannot figure out if it’s a software or a hardware issue.

I tried searching over the forum but I could not find anything related to my experience. Any advice would be appreciated.

Hi @ar_0,

This could possibly be because of a keyboard layout mis-configuration. I think.

What is the output of:


Check that the correct layout is there,

I would usually expect this to be hardware related.
That the keys become functional after some time … makes this slightly less certain … but only if it is reliably so. It could simply be a symptom of a dying connection that becomes just barely connected again due to some factors like heat during operation … but will eventually fail altogether.
One way to test out the hardware theory would be to use some other systems - create a Ventoy usb, throw a few ISO’s on there, boot them up, and observe whether the keyboard functions normally.


Thanks @cscs for your reply. I created a Ventoy usb and booted it up and the keys were still not working so I just have to accept that it is an hardware issue.