Some issue with Manjaro KDE installer, no bootable EFI partition

There’s definitely an issue with the latest KDE image’s installer. First I’ll say that I have Manjaro KDE installed on about 5 systems and Manjaro Gnome on 2. My Desktop Gnome install broke on an update and rather than fiddling with it a whole lot I just decided to reinstall since all my data is on non-system disks and a NAS anyway.

I run Gnome on this machine because KDE didn’t seem terribly stable on it when I first built it (multiple monitors, newest hardware). Gnome ran alot better but I prefer KDE so I tried to install that this morning. No matter what I could not get a bootable install from the installer. I did the same things I always do…

Manually partition:
New partition table on PCIE SSD
512mb boot partition (boot flag, /boot/efi mount point, fat32)
100gb / partition (ext4)
840gb /home partition (ext4)
32gb swap (linuxswap)
couple gigs unpartitioned.

esp flag is no longer available but searching the forum suggests it’s no longer necessary. CSM is off in my bios so I know I didn’t boot the installer in legacy. My bios could not recognize a bootable disk after trying several times I’m sure there is some workaround but I could not find it.

Got tired of it and downloaded the latest Gnome install, did the exact same thing listed above 1 time and the install is bootable, using it now.


You have to install gparted
And set the flag for the boot partition to esp (tick boot and esp only in mount flag)
On kde partition partition manager the settings is deep inside
But still I don’t understand why they don’t add the gparted app to the kde iso
Its a pain when u installed kde and no boot options later
If u want gparted, u have to update pendrive one and install gparted -_-

1 Like

My partitioning scheme is the exact same style as yours, I used the same options, and I’m having the same problem:
Trying to reboot the installed system, there is not bootable partition.
Also the thing with the esp flag missing from 1. KDE partition manager and 2. Calamares installer:
There’s about a dozen threads of people put off by this - The official Manajro user guide still has the version with esp flag.
Some users and moderators claim it’s fine, only the “boot” flag is needed, which > no, not in my case and yours - and several more, as we can see around the forum (it does seem to have worked for some).
Can we please just put that esp flag back in the installer?
I mean this thread is three months old, still the same situation.

1 Like

I did as suggested, booted the live Manjaro system from usb a 5th time, and installed Gparted from the repos (had to download repo database first, so pacman -Sy gparted).
In Gparted, I found that

  1. the boot/efi partition did have the esp flag activated along with the boot flag.
  2. the root, home and boot partition all had the legacy boot flag activated for reasons unknown. I surely did not do that myself, given that neither KDE partman nor Calamares even show thess options.

I removed the legacy boot flag from all the partitions.

Then there was another strange thing that may or may not have made a difference:
Gparted reported not being able to read the fat32 file system:

“Reason could be a missing software package, dosfstools and mtools are required for supporting the fat32 file system”.
I found that mtools was indeed missing - but then how was I able to create an fat32 partition from this live medium? - and I installed it.

Shut down the live session, reboot: voila, Manjaro boots from system drive.

I think that the Manajro team should:

  • re-investigate how both KDE partition manager and Calamares installer set the boot flags.
  • clear things up in documentation such as the official User Guide.

Same happening here… and Im reading threads for long ago (even 2020) from people having the same issue as me. It seems it has not been fixed yet nor they discovered what is causing this problem. Quite frustrating, isnt it?

I think Im gonna move to KDE Neon or even Arco until this mess is fixed. Maybe in 2 or 3 years from now. Its a pity since I love Manjaro, but I don`t have time to investigate it further I need to work and I need something that works as intended.

That is strange. I just installed Manjaro KDE 21.0.5 today, but the automatic installation. I do not need a separate home.partition. And the EFI partition is set to boot/esp. Why should it be set to esp if it is no longer necessary?

I would suggest that the question of whether or not the esp flag is necessary is still up for discussion.
My case suggests that it doesn’t need to be set explicitly in Calamares or KDE partman, but it is there, these two programs just decide to hide it for some reason.
Just see if it works for you if you disable esp, then you’ll know if it was necessary.

1 Like