Some (gtk?) programs have wrong color theme on i3 after recent update

Since this update, some programs have a wrong color theme.

I use a dark theme (no idea when and where I’ve set it), but for example:

  • Vivaldi’s menus are now suddenly with white background
  • baobab has white background

I’m sure this is easy to fix, but I have no idea where to start and what to change. Any suggestion is appreciated.

What desktop environment are you using?
Most straight forward thing to try would be going into settings and switching to another theme and back.
If you are using e.g. KDE and this only applies to gtk apps ( as Baobab is, I think), try looking for the theme settings for gtk apps specifically. Don’t forget to restart those apps after you do so.

I’m using i3 (and I guess KDE? or was it XFCE?).

I’ve tried KvantumManager, qt5-settings, qt6-settings and lxappearance. Whatever I tried there didn’t change a thing.
Am I missing something there, or should I be looking at some different location?

I’ve never used i3 as a windows manager, so it might not work the same for you. But for me, on “normal” KDE Plasma, I can change gtk appearance under System settings, where there’s a tab for appearance of apps, including Gnome/gtk apps. Sorry for not being more specific, I’m not using english language settings and thus can’t tell the exact names in the menu.

this would work for baobab:
in the specified path as administrator(root)
open the “org.gnome.baobab.desktop”
and change line:
Exec=env GTK_THEME=Matcha-dark-sea baobab %U

Baobab (also for example
gnome-logs) now uses gtk4 and you should use a gtk3/gtk4 compatible theme, or just copy the gtk.css file from your theme to ~/.config/gtk-4.0/

Thanks for the suggestion! It made perfect sense, but:

I’ve copied the whole ~/.config/gtk-3.0/ to ~/.config/gtk-4.0/, but it didn’t help.

Here are the contents of gtk.css:

.window-frame {
  box-shadow: none;
  margin: 0;

When I change a theme in LXAppearance, it changes the theme only in the gtk-3.0 folder. Manually copying it to the gtk-4.0 also didn’t help.

I’m using Adapta-Nokto-Eta-Maia. I don’t know how to check if it is gtk4 compatible.
Now I’ve tried also Matcha-dark-sea, and I can see for example Thunar and Deadbeef changing their appearance, but Baobab is still with white background, as are menus in Vivaldi.

I’m using Manjaro XFCE, look after the last update I had the same problem with Baobab and gnome-logs I had to construct my own gtk.css. I’m using the Cloudy-Solid-SoftGrey-Dark theme with some modifications.
In this theme for the background is:
@define-color theme_bg_color #212121;
In ~/.config/gtk-4.0/gtk.css I added for the background:
@define-color window_bg_color #212121;
Try this.

This resulted in this:

Background is now black, but the text on it is also black and unreadable, and the titlebar is still light.

Thanks for the help nonetheless!

I told you where to look, I’m not going to remake gtk.css for you. You need to think, search, create yourself, this is normal, at least in the world of free software. Come on, I believe in you!

1 Like