Some AUR packages can't install anymore

Hello! Recently I’ve been running into errors when installing some AUR packages.

Today, I tried reinstalling ‘cava’ via sudo pamac install cava but at the end the output returns: installing './depcomp'
mkdir: cannot create directory ‘/.config’: Read-only file system
cp: cannot create regular file '/.config/cava/config': No such file or directory
==> ERROR: A failure occurred in build().
Finished with result: exit-code
Main processes terminated with: code=exited/status=4

This is strange because the first time I installed cava I ran into no issues. This error seems to be happening with numerous packages recently.

An attempt to install ‘spotify-tui’ via sudo pamac install spotify-tui returns a similar error.

==> Starting build()...
error: failed to get `anyhow` as a dependency of package `spotify-tui v0.24.0 (/var/cache/private/pamac/spotify-tui/src/spotify-tui-0.24.0)`

Caused by:
  failed to create directory `/.cargo/registry/index/`

Caused by:
  Read-only file system (os error 30)
==> ERROR: A failure occurred in build().
Finished with result: exit-code
Main processes terminated with: code=exited/status=4

A look with journalctl -p3 -b -0 and I find:

Aug 22 13:20:01 system systemd[1]: Failed to start /usr/bin/makepkg -cCf --nosign PKGDEST=/var/cache/pamac/cava PKGEXT=.pkg.tar.
Aug 22 13:21:44 system systemd[1]: Failed to start /usr/bin/makepkg -cCf --nosign PKGDEST=/var/cache/pamac/spotify-tui PKGEXT=.pkg.tar.

Some packages like audio-recorder still can be installed, so I’m not sure whats causing these packages to fail during installation.

Here’s what inxi --full --verbosity=7 --filter --no-host outputs just in case:

System:    Kernel: 5.13.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2
           info: i3bar, polybar wm: i3 4.19.1 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401IV_GA401IV v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: GA401IV v: 1.0 serial: <filter> UEFI: American Megatrends v: GA401IV.219 date: 12/30/2020
Battery:   ID-1: BAT0 charge: 15.9 Wh (22.9%) condition: 69.3/76.0 Wh (91.2%) volts: 15.8 min: 15.8
           model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging
Memory:    RAM: total: 15.06 GiB used: 2.94 GiB (19.5%)
           RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:       Info: 8-Core model: AMD Ryzen 9 4900HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 rev: 1 cache:
           L2: 4 MiB bogomips: 95854
           Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397
           6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397 12: 1398 13: 1397 14: 1395 15: 1397 16: 1397
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext cat_l3 cdp_l3 clflush
           clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
           cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht
           hw_pstate ibpb ibrs ibs irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx
           nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
           perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev
           sev_es sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall
           tce topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave
           xsavec xsaveerptr xsaveopt xsaves
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Max-Q] vendor: ASUSTeK driver: nvidia v: 470.63.01 bus-ID: 01:00.0
           chip-ID: 10de:1f12 class-ID: 0300
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 04:00.0
           chip-ID: 1002:1636 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: picom v: git-dac85 driver: loaded: amdgpu,ati,nvidia
           unloaded: modesetting,nouveau alternate: fbdev,nv,vesa resolution: 1920x1080~120Hz s-dpi: 96
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.11-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.1.6 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
           class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A
           bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.11-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.33 running: no
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 bus-ID: 02:00.0 chip-ID: 8086:2723
           class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter>
           IP v6: <filter> type: noprefixroute scope: link
           WAN IP: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-4:3 chip-ID: 8087:0029 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Logical:   Message: No logical block device data found.
RAID:      Message: No RAID data found.
Drives:    Local Storage: total: 953.87 GiB used: 24.54 GiB (2.6%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPNPZ-1T00-1002 size: 953.87 GiB speed: 31.6 Gb/s
           lanes: 4 type: SSD serial: <filter> rev: 21106000 temp: 44.9 C scheme: GPT
           Message: No optical or floppy data found.
Partition: ID-1: / size: 122.48 GiB used: 24.52 GiB (20.0%) fs: ext4 dev: /dev/nvme0n1p6 label: N/A
           uuid: 32f960f9-6bab-483b-a810-610df61ebcc7
           ID-2: /boot/efi size: 256 MiB used: 25.5 MiB (10.0%) fs: vfat dev: /dev/nvme0n1p1 label: SYSTEM uuid: 6403-7909
Swap:      Alert: No swap data was found.
Unmounted: ID-1: /dev/nvme0n1p2 size: 16 MiB fs: <superuser required> label: N/A uuid: N/A
           ID-2: /dev/nvme0n1p3 size: 808.22 GiB fs: ntfs label: OS uuid: B4E20553E2051AEE
           ID-3: /dev/nvme0n1p4 size: 900 MiB fs: ntfs label: RECOVERY uuid: C0CC329CCC328CA2
           ID-4: /dev/nvme0n1p5 size: 19.5 GiB fs: ntfs label: RESTORE uuid: 1E5665A356657D01
USB:       Hub-1: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
           Device-1: 3-3:2 info: ASUSTek N-KEY Device type: Keyboard driver: asus,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
           power: 100mA chip-ID: 0b05:1866 class-ID: 0301
           Hub-2: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900
           Hub-3: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
           Device-1: 5-3:2 info: Shenzhen Goodix FingerPrint type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0
           speed: 12 Mb/s power: 100mA chip-ID: 27c6:521d class-ID: ff00
           Device-2: 5-4:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
           power: 100mA chip-ID: 8087:0029 class-ID: e001
           Hub-4: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900
Sensors:   System Temperatures: cpu: 44.9 C mobo: 44.0 C
           Fan Speeds (RPM): cpu: 2500
Info:      Processes: 389 Uptime: 38m wakeups: 198 Init: systemd v: 248 Compilers: gcc: 11.1.0 Packages: 1371 pacman: 1363
           flatpak: 5 snap: 3 Shell: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.06

Any help on this issue will be appreciated!

You’re doing it wrong. First of all, pamac is never to be used with sudo, because it will prompt you for the password when needed. Running it with sudo means that it will do the downloading and ─ in the case of AUR packages ─ compiling as root, which is to be avoided at all time.

Secondly, the pamac command for installing AUR packages is not install but build. :arrow_down:

pamac build <name-of-aur-package>

Thanks! I didn’t encounter any errors after using pamac build. What is the difference between pamac install and pamac build? (As pamac install is also listed as an available option)

You commonly use the install option with packages from the regular Manjaro repositories, while you use build with AUR packages.

AUR packages are usually supplied as links to various source code repositories, in a script called PKGBUILD. The build option to pamac checks this PKGBUILD file and pulls in whatever the file specifies, then builds the software into a readily installable binary package, and then finally, installs it.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.