Some ASUS GL702ZC boot issues

At this point I’ve had this Manjaro installation on the laptop for more than 3 years. While everything works fine, I’m currently having some boot issues.

Light Display Manager now often fails to start. I don’t know which log I should provide in order to reliably diagnose the issue, although this is not a serious one. Back then a reboot would usually work, but not anymore recently.

The issue worsened after a certain unclean shutdown. At that time, the system’s udev was kind of hung thanks to an unstable USB-C cable, which caused the system freeze when X server closed after I clicked Restart from the XFCE menu. I had to manually power off and back on, and then this issue happened. While in rare cases I could get it booted to the GUI (the LightDM GTK Greeter shows up), in most cases it would end up stuck and I have to switch to another terminal, log in, and manually startx which works.

The /var/log/Xorg.0.log of the failed X startup looks strange, as it mentioned a lot of modules (such as fbdev, radeon, vesa), EXCEPT amdgpu, and eventually it ended up with these errors.

[     5.253] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.253] (EE) open /dev/dri/card0: No such file or directory
[     5.253] (WW) Falling back to old probe method for modesetting
[     5.253] (EE) open /dev/dri/card0: No such file or directory
[     5.253] (EE) Screen 0 deleted because of no matching config section.
[     5.253] (II) UnloadModule: "modesetting"
[     5.253] (EE) Device(s) detected, but none match those in the config file.
[     5.253] (EE) 
Fatal server error:
[     5.253] (EE) no screens found(EE) 
[     5.253] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[     5.253] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     5.253] (EE) 
[     5.253] (EE) Server terminated with error (1). Closing log file.

My /etc/X11/xorg.conf.d doesn’t really have any screen related confs that are active, and that my /etc/X11/mhwd.d is empty. I even tried actually installing video-linux from Manjaro Settings Manager but no avail (it installed some other drivers anyway). I don’t know if these are normal and if so, where else should I look to find the real cause of the issue?

I’m currently on the most recent stable update with a 5.14 kernel, by the way.

EDIT: A few days ago when the issue actually started worsened it didn’t say “Failed to start Light Display Manager” (such occurrence were as rare as before), but now it almost always says that, and journalctl is not giving me anything helpful other than the fact it failed with error code (which is probably because X didn’t start correctly).

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Have you tried an LTS kernel already?


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

I’m on 5.14 kernel. Actually I replaced the laptop’s old Wi-Fi module with an Intel AX210 whose Bluetooth part does not work correctly with earlier kernels (before 5.12, I think).

It seems lightdm is really a bit broken as now I just rebooted like 5 times and still fails. I did manage to boot to the desktop the first time I powered it on today, though.

I suspect the issues are the same as /var/log/Xorg.0.log is giving me the same errors.

It’s not really a big issue at the moment as I can always startx after switching to tty2 to actually get into the desktop and everything works. Just that some system colors would be different (not an issue) and that I have to start some other stuffs manually (namely ibus-daemon).

A late bump on this. For some reasons the issue went away by itself. I didn’t encounter the issue at all during this week. Maybe some updates improved it, but I don’t know which exactly and I can’t be sure if the issue is really gone.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.