Some apps crash when attaching documents to messages

Hi there,
I have a problem with certain messaging apps (Skype, Signal, but not Viber). When I try to attach a document to a message, the moment I select the file and click “Open”, the app crushes and a blank screen is shown. After that there is no response, I have to close and reopen the app (the top toolbar is still clickable, but it doesn’t do anything).

I have tried .pdf, .l and .c extensions so far, and they all get the same result.
I can send images normally.

When I run the apps from the command line, after the crush I get these messages:


(skypeforlinux:7078): Gtk-WARNING **: 14:18:35.790: Error loading theme icon 'doc
ument-open' for stock: Icon 'document-open' not present in theme breeze-dark

This is repeated many times and is followed by:

Failed to generate minidump.

I should note here that I tried also to change the theme from breeze-dark to breeze and the problem persisted.


21-03-19T12:29:25.023Z","msg":"Was unable to generate thumbnail for file type  {\
21-03-19T12:29:25.032Z","msg":"Top-level unhandled promise rejection: {\"isTruste

What I understand is that for some reason the thumbnails/icons for documents are not accessible by the apps, so they crush. Also I speculate that Viber uses it’s own icons, so it doesn’t have such a problem.

My system details (using uname -a):

Linux MyComputerName 5.11.6-1-MANJARO #1 SMP PREEMPT Thu Mar 11 19:05:51 UTC 2021 x86_64 GNU/Linux

Hi @DimiD,

I’m sorry for the obvious question, but since it sounds like a missing file or permissions problem I’ve got to ask, have you tried reinstalling the apps?


If it’s not that, well, then I don’t know…

Hi @Mirdarthos
I have, and unfortunately the problem persists.
Thanks for the reply though!