Some apps aren't opening

I just installed Manjaro GNOME on my PC.

After booting to Manjaro wanted to open the Settings app, but for some reason after clicking on the Settings app it just changes the cursor to a loading for few seconds and reverts back to the pointer cursor. (this also happens when I try to open the Printer app).

Try opening an app from the terminal then copying the output here.

1 Like

how do I do that?
very sorry for asking, I’m really new on the whole linux thing.

You simply put the name of the application in a terminal as a command then press enter. For example if steam was having issues launching you put steam then run the command.

Just booted up a Gnome ISO, command to run to open gnome settings is gnome-control-center

No problem. Welcome to Manjaro

zsh: correct 'settings' to 'gsettings' [nyae]? n
zsh: command not found: settings

I also tried running it as root

# settings
-bash: settings: command not found

then I tried to open firefox, it worked firefox opened.


Run that

# gnome-control-center
gnome-control-center: error while loading shared libraries: cannot open shared object file: No such file or directory

this is what fired back

Sounds one of the following may be true:

  • The system is not up to date
  • The system is in a partial upgrade state
  • A reboot has not been performed after updating

Update your mirrors and check for updates:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

I runned the command and restarted my pc also, I still get the same error when running


Finally managed to fix it by searching on Firefox for hours and stumbled across the pkgs(dot)org site, searched the name of the library that throws the error and followed the how to instructions for the arch linux.

1. Enable the extra repository on /etc/pacman.conf:

    Include = /etc/pacman.d/mirrorlist

2. Install webkit2gtk zst package:

    # pacman -Syu webkit2gtk

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.