Some apps are unresponsive and don't launch

I have this annoying problem that happens with some of the apps like VeraCrypt, Deepin File Manager, Audacity, Firefox. When I try to launch an app, say VeraCrypt or Firefox, nothing happens. The app doesn’t start.

These apps that I mentioned here were running fine without any problem upon installation, and ran fine for days and weeks but at some point something happened. Maybe it happened after a huge 2GB update where so many apps and kernel got updated. I don’t know exactly when and why it happened.

Firefox that I was previously using that I had a problem with was downloaded from the Official Repositories. Uninstalling Firefox and reinstalling it from Flatpak packages fixed the problem with Firefox. Uninstalling and reinstalling Audacity fixed the problem too. So far so good! But I was not that lucky with VeraCrypt. It didn’t matter which package of VeraCrypt I reinstalled, none of them worked! All were unresponsive and did not launch! I booted up Manjaro with a different kernel. It didn’t help either!

Any idea?

Below is my system information:
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.17.9-1-MANJARO (64-bit)
Graphics Platform: X11

Thank you.

provide formated output from:
inxi -Fazy
and run veracrypt from terminal, and see if there are any hints

Thank you, Brahma for your response to my message.

The output of inxi -Fazy is

Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
root=UUID=d91d3223-d93c-40eb-a4f9-149d335da526 rw quiet
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: cairo-dock
wm: kwin_x11 vt: 1 dm: 1: LightDM v: 1.30.0 note: stopped 2: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: Micro-Star product: GS76 Stealth 11UG v: REV:1.0
serial: Chassis: type: 10 serial:
Mobo: Micro-Star model: MS-17M1 v: REV:1.0 serial:
UEFI: American Megatrends LLC. v: E17M1IMS.118 date: 04/25/2022
ID-1: BAT1 charge: 55.5 Wh (60.1%) condition: 92.4/95.0 Wh (97.2%)
volts: 15.8 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A status: N/A
Device-1: hidpp_battery_0
model: Logitech Wireless Mobile Mouse MX Anywhere 2S serial:
charge: 10% (should be ignored) rechargeable: yes status: discharging
Info: model: 11th Gen Intel Core i9-11900H bits: 64 type: MT MCP
arch: Tiger Lake family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x3E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4800:4900 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 801 12: 801 13: 800 14: 800
15: 801 16: 800 bogomips: 79888
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Micro-Star MSI
driver: i915 v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4
bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q]
vendor: Micro-Star MSI driver: nvidia v: 470.129.06
alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-05) arch: Ampere pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
empty: DP-5, DP-6, HDMI-A-1, eDP-2 bus-ID: 01:00.0 chip-ID: 10de:249d
class-ID: 0300
Device-3: Acer HD Camera type: USB driver: uvcvideo bus-ID: 3-11:3
chip-ID: 5986:2127 class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP-1-1 model: BOE Display 0x09f9 built: 2021
res: 1920x1080 hz: 60 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43")
diag: 437mm (17.2") ratio: 16:9 modes: 2560x1440
OpenGL: renderer: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2
v: 4.6.0 NVIDIA 470.129.06 direct render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0401
Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.51 running: yes
Device-1: Realtek Killer E3000 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 59:00.0
chip-ID: 10ec:3000 class-ID: 0200
IF: enp89s0 state: down mac:
Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 5c:00.0 chip-ID: 8086:2725 class-ID: 0280
IF: wlp92s0 state: up mac:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:6 chip-ID: 8087:0032 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 953.87 GiB used: 67.1 GiB (7.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 MTFDKBA1T0TFH
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: rev: P7MA000 temp: 21.9 C scheme: GPT
Alert: No swap data was found.
System Temperatures: cpu: 38.0 C mobo: N/A gpu: nvidia temp: 29 C
Fan Speeds (RPM): N/A
Processes: 350 Uptime: 5m wakeups: 122 Memory: 31.06 GiB
used: 2.37 GiB (7.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: 1903 apt: 0 pacman: 1859 lib: 475
flatpak: 27 snap: 17 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.16

When I try to run VeraCrypt from terminal, I get the message below.

veracrypt: error while loading shared libraries: cannot open shared object file: No such file or directory

It looks like the library (, needed to run VeraCrypt is not installed or missing.

I tried to look up and download in Pamac, but nothing is coming up. “” may be a part of a bigger library under a different name. It is beyond me why uninstalling and reinstalling VeraCrypt would not install whatever library or file needed to run VeraCrypt.

is veracrypt installed from official repositories?

Do you have wxgtk3 and wxgtk-common installed?


Yes, it is installed from official repositories.

I have all these 3 installed.
3)wxgtk2-dev (which has a dependency of “wxgtk-common-dev”)

So, I uninstalled both wxgtk2-dev and wxgtk-common-dev and installed wxgtk-common. Lo and behold! VeraCrypt is working again!

We have an amazing forum!

Thank you, Richard!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.