Some applications take more than half a minute to open

Hi, after an update from a couple of weeks ago some of my apps take up to a full minute to open… I updated using pamac manager and i do have some aur packages.
I tried opening them with a terminal but nothing shows up for that whole minute until they manage to start…
The apps seem to be using gtk as far as i understand and they all work after that delay except spotify, which just shows a black screen after the delay in opening. Vivaldi-stable is from the official repository and it also takes a lot of time to open (~20 seconds) even if it’s already open and i try to open a link using xdg-open…

all i can see with strace is just a flood of these calls:

[pid 3804658] 11:30:00.964560 futex(0x7f0f8412d7c0, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, {tv_sec=1656408601, tv_nsec=63452378}, FUTEX_BITSET_MATCH_ANY <unfinished ...>
[pid 3804626] 11:30:00.976425 <... epoll_wait resumed>[{events=EPOLLIN, data={u32=78019380, u64=78019380}}], 128, -1) = 1
[pid 3804626] 11:30:00.976621 clock_gettime(CLOCK_REALTIME, {tv_sec=1656408600, tv_nsec=976685676}) = 0
[pid 3804626] 11:30:00.976994 timerfd_settime(51, 0, {it_interval={tv_sec=0, tv_nsec=0}, it_value={tv_sec=300, tv_nsec=0}}, {it_interval={tv_sec=0, tv_nsec=0}, it_value={tv_sec=0, tv_nsec=0}}) = 0
[pid 3804626] 11:30:00.977378 clock_gettime(CLOCK_MONOTONIC, {tv_sec=33426, tv_nsec=714940920}) = 0
[pid 3804626] 11:30:00.977582 clock_gettime(CLOCK_REALTIME, {tv_sec=1656408600, tv_nsec=977610442}) = 0
[pid 3804626] 11:30:00.977665 clock_gettime(CLOCK_REALTIME, {tv_sec=1656408600, tv_nsec=977684963}) = 0
[pid 3804626] 11:30:00.977746 timerfd_settime(51, 0, {it_interval={tv_sec=0, tv_nsec=0}, it_value={tv_sec=0, tv_nsec=48926000}}, {it_interval={tv_sec=0, tv_nsec=0}, it_value={tv_sec=299, tv_nsec=999307595}}) = 0

which i don’t really understand. I can include full log if needed…
Journalctl didn’t seem to contain anything useful either.

the closest thing i managed to find while searching around is a page ( which i apparently can’t link ) on the arch support forum, but they were talking about things like gcolor3, some desktop portal thing etc which i have none of those installed… So i don’t know what to do and no solutions in that thread worked for me.

I have no idea how to fix this, nor how to better troubleshoot, i’d appreciate any help. Thanks.

Remove the AUR packages - to eliminate a missing rebuild - as a rule of thumb - AUR packages likely needs to rebuilt after an system sync. That is not likely to be true in each an every usecase - but it is due diligence to keep it in mind.

1 Like

When you open such application, do you have any software running which consumes a lot of CPU and/or disk read/write?

No, it happens even just after a restart, cpu usage being minimal and even while under stress the times and outcomes are basically the same

I tried removing all the AUR packages i didn’t need and rebuilding all of the ones i still have but nothing changed. (Again, vivaldi-stable is from the official repositories and all its dependencies too)… So i really don’t know what is going on…

Am i really the only one to be experiencing this? After 2 system wide updates i still have this problem. I rebuilt the few aur packages i have, but i still have the same problem…

Would anybody be so kind as to at least help me out a bit on which ways could i further debug this on my own?

Does the same happen, when you add a new user to your system and start these applications with the new account? Maybe it’s not a systemwide problem, only a configuration issue in your $HOME.

1 Like

THANK YOU so much. I created a new user and it indeed worked. All apps open instantly. Is there something more specific i could look into to solve the problem on my main user account? Maybe permissions? Since apparently spotify also works, while it just displays a black screen on my main.

clear everything in the .cache folder in home on your main account, then reboot and see if it helped

Unfortunately clearing cache did nothing…

so rename the .config folder in home to .config.bak, reboot and see if this helped

that just broke my main user… Lots of stuff not working anymore even now that i have brought back the .config folder from the bak… I guess problem solved since i have to recreate it lol…

you need to delete the new config that was created, then rename back the .config.bak to .config, then reboot

yeah i did that… I’m getting lots of permission errors with lots of apps. I’m trying to see if i can solve it. The apps that weren’t working before are working now though lol

yes renaming the .config should help… and what permission errors, post them here

My fault i did something wrong. Fixed the mistake. Now i got my old config back and the original problem represented. So i know the problem is in .config. Thank you.
Should i try deleting the caches inside .config?
edit: it’s not solving anything. I deleted the spotify folder inside .config but it still doesn’t work… Which means there’s probably some deeper problem inside that folder… I don’t know how to troubleshoot the specific apps or i would’ve done that…

the problem is not with spotify, but with some gnome/system config, that messes the apps, not even reinstalling the affected apps would probably help on your main account… if you wish you can post here the list aff all items in your config folder

you can test it, remove the spotify folder from .config folder, reboot and see if the issue is resolved… dont delete the spotify folder, just cut it from the config folder and paste it somewhere else, reboot

already did that… Not working, which makes me think it’s some setting inside xprofile, xresources etc… Which is weird because i don’t remember editing them in a long time

you can try this:
rename again the .config to .config.bak
copy the .config from the new user into the main user, reboot and see if it helped, if yes, just copy the programs configs from spotify, your browsers … etc from the config.bak into the .config