Some applications rendered too big in GNOME until display manager restart

Hi everybody,

since I recently updated my system, I’m suddenly getting issues with some applications being rendered at twice the scale. Mouse interactions with such applications are nearly impossible, because the mouse position is interpreted as if the application was rendered correctly, but what I’m seeing is blurry and doesn’t fit the monitor it is located on. If the application is focused (in the foreground), parts of it are rendered on adjacent monitors, overlapping neighboring applications. Only way I found to fix it is restarting the display manager (Alt-F2 > r), which always causes my window positions to get lost and is very annoying. Fortunately, the application with broken scale is fixed after restarting the display manager and I can continue my work until I open another window that has the same issue.

This is how it looks (Thunderbird window in the bottom, right):

Applications I’m having issues with

  • Thunderbird
  • Remmina (RDP client)
  • GIMP

I’m using this system:

  • kernel 6.3.12-1
  • GNOME with Pop Shell extension
  • X11
  • optimus-manager, always set to nvidia mode

mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI

Warning: No installed USB configs!

sudo systemctl status optimus-manager.service:

[sudo] password for meides: 
● optimus-manager.service - Optimus Manager Commands Daemon
     Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; enabled; preset: disabled)
     Active: active (running) since Thu 2023-07-13 20:23:26 CEST; 4 days ago
   Main PID: 2554 (python3)
      Tasks: 1 (limit: 76764)
     Memory: 6.9M
        CPU: 4.074s
     CGroup: /system.slice/optimus-manager.service
             └─2554 /usr/bin/python3 -u -m optimus_manager.daemon

Jul 13 20:23:22 key15 python3[960]: [248] INFO: Writing "on" to /sys/bus/pci/devices/0000:01:00.1/power/control
Jul 13 20:23:22 key15 python3[960]: [254] INFO: Loading module nvidia
Jul 13 20:23:24 key15 python3[960]: [2575] INFO: Loading module nvidia_drm
Jul 13 20:23:26 key15 python3[960]: [4205] INFO: Writing to /etc/X11/xorg.conf.d/10-optimus-manager.conf
Jul 13 20:23:26 key15 python3[960]: [4205] INFO: Writing state {'type': 'pending_post_xorg_start', 'switch_id': '20230713T202321', 'requested_mode': 'nvidia'}
Jul 13 20:23:26 key15 python3[960]: [4206] INFO: Xorg pre-start hook completed successfully.
Jul 13 20:23:26 key15 systemd[1]: Started Optimus Manager Commands Daemon.
Jul 13 20:23:26 key15 python3[2554]: [1] INFO: # Commands daemon
Jul 13 20:23:26 key15 python3[2554]: [1] INFO: Opening UNIX socket
Jul 13 20:23:26 key15 python3[2554]: [2] INFO: Awaiting commands

A colleague of mine uses a similar setup and faces the same issues since a recent update.

I already tried, without luck

  • downgrading the kernel
  • Instead of restarting the display manager, changing the scale in the setting to 200% and back to 100%
  • Turning the Pop Shell extension off and turning it back on again
  • Closing and re-opening a window if it has issues. No use, it seems to be very deterministic.

Any ideas what could have caused this and what I could try next?

It’s a known issue with tiling extensions like Pop Shell and Forge.

Press Super+M or Double-click on the title bar of the program twice in a row to maximize / un-maximize the window. This is assuming you have Tweaks > Window Titlebars > Titlebar Actions > Double-Click set to Toggle Maximize

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.