[SOLVED/Workaround] Can't use WPA3-SAE networks

Update: Solved;
This is actually a bug if using the system tray; If you manually specify a new connection instead of selecting + connecting via the system tray it will connect successfully.

I’ve recently changed my router to exclusively use WPA3-SAE.
While this laptop runs Window it can connect without issue.

However while using Manjaro I get

“Failed to add connection”
802-11-wireless-security.key-mgmt: Access point does not support PSK but setting requires it."

I’m thinking there may be a misconfiguration or driver related change to properly work with WPA3-SAE access points.


lspci shows:

00:14.3 Network controller: Intel Corporation Cannon Lake PCH CNVi WiFi (rev 10)
3c:00.0 Ethernet controller: Qualcomm Atheros Killer E2500 Gigabit Ethernet Controller (rev 10)

The laptop specification shows

Killer Gb LAN
Killer ac Wi-Fi + Bluetooth v5

Update: This actually appears to be a bug when using the system tray Wi-Fi icon to connect to the network.

If I manually create the connection via System Settings and specify as WPA3 Personal it is able to connect without issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.