[SOLVED] Wifi pretends to not work for two minutes


#1

Manjaro Wifi pretends to not work for two minutes. Constantly tells me that it cannot connect to wifi so i have to keep clicking disconnect and connect, until around the fifth attempt, it finally connects. Why is this? Can someone help me? Do i need to install the correct driver? lspci -nn -d 14e4: 05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)


#2

@tbg: new customer

@archlinux4lifegang give us your inxi -Fxz in readable format please
For future references: give as much info as possible or it will be very hard to help you.


#3

Reboot your home router first before assuming you have a Manjaro wifi problem. Over 90% of WiFi issues are router-network based.


#4

There are a couple of posts about that model
https://forum.manjaro.org/search?q=BCM4360%20


#5
System:
  Host: terran-PC-workstation Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
  Distro: Manjaro Linux 
Machine:
  Type: Unknown Mobo: Intel model: DX58SO v: AAE29331-703 serial: <filter> 
  UEFI: Intel v: SOX5810J.86A.5600.2013.0729.2250 date: 07/29/2013 
CPU:
  Topology: Quad Core model: Intel Core i7 950 bits: 64 type: MT MCP 
  arch: Nehalem rev: 5 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49750 
  Speed: 1621 MHz min/max: 1596/3192 MHz Core speeds (MHz): 1: 1621 2: 1636 
  3: 1622 4: 1659 5: 1626 6: 1715 7: 1621 8: 1621 
Graphics:
  Device-1: AMD Juniper XT [Radeon HD 5770] vendor: XFX Pine driver: radeon 
  v: kernel bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: modesetting 
  resolution: 1360x768~60Hz, 1440x900~60Hz 
  OpenGL: renderer: AMD JUNIPER (DRM 2.50.0 / 4.19.16-1-MANJARO LLVM 7.0.1) 
  v: 3.3 Mesa 18.3.2 direct render: Yes 
Audio:
  Device-1: Intel 82801JI HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Device-2: AMD Juniper HDMI Audio [Radeon HD 5700 Series] vendor: XFX Pine 
  driver: snd_hda_intel v: kernel bus ID: 02:00.1 
  Sound Server: ALSA v: k4.19.16-1-MANJARO 
Network:
  Device-1: Intel 82567LM-2 Gigabit Network driver: e1000e v: 3.2.6-k 
  port: 3100 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: wl v: kernel port: 2000 bus ID: 05:00.0 
  IF: wlp5s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.13 TiB used: 10.25 GiB (0.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-00BN5A0 
  size: 931.51 GiB 
  ID-2: /dev/sdb vendor: Kingston model: SV300S37A240G size: 223.57 GiB 
RAID:
  Hardware-1: Marvell 88SE6111/6121 SATA II / PATA Controller 
  driver: pata_marvell v: 0.1.6 bus ID: 06:00.0 
Partition:
  ID-1: / size: 206.08 GiB used: 10.25 GiB (5.0%) fs: ext4 dev: /dev/sdb2 
  ID-2: swap-1 size: 12.89 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: radeon temp: 39 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 311 Uptime: 2h 36m Memory: 11.71 GiB used: 1.13 GiB (9.6%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.30 

#6

A few suggestions.

If you control your router/AP, then go into the routers web configurator and set the router channel to 36 or 40 on the 5Ghz band.

Upgrade to kernel 4.20. I believe the broadcom-wl has been reported to be experiencing issues on 4.19. If 4.20 is no better then install kernel 4.14 through Manjaro Settings Manager. Always keep at least two kernels installed.

If there is no improvement then try uninstalling the broadcom-wl driver through Manjaro Settings Manager. After you reboot the kernel driver/module should automatically be loaded. The kernel module has been working better than the wl driver for some recently.

A few questions:

Has the connection been dropping at regular intervals like every ten minutes, or is it sporadic?

Is it affected by downloads or streaming video, or does it happen when simply browsing webpages or when idle?


#7

Can you help me out? I am going to have to reinstall Manjaro since now my Wifi is saying, “Devices not ready.”
So… I am going to need help how to install the wireless driver OFFLINE. I am going to go tothe AUR website, download the broadcom-wl package (i just dont know which one to download) and i plan to install the package offline (i dont know how to do this either. sudo pamac?)

and to answer your question: My internet doesn’t act up at all. It is only when i boot into my computer, i manually connect to my wifi, but it constantly tells me “cannot connect” for at least 2 minutes, looping symbol. Then, after I disconnect manually and connect again, it finally establishes a connection and no problem after that. i just didnt want to have to do that everyday so i wanted help with that.

but now i did something to my wifi and now the devices arent ready so i am going to reinstall manjaro offline.


#8

@archlinux4lifegang :point_up_2:

open manjaro setting manager and uninstall the wl-broadcom drivers and then reboot.

what did you do, state your actions up to this point.

why? if networking works on the live usb then you have wifi


#9

Actually, networking does not work during live usb. I connect directly with ethernet,

I did a modprobe on b43 and all of them. But i just opened up the broadcom file located in /etc/modprobe.d and i deleted all that was blacklisted and including the file.

i uninstalled the broadcom driver via package manager

I downloaded this file from AUR https://aur.archlinux.org/packages/broadcom-wl-ck/

i just did a sudo pacman -U tar.gz

so now i will check if it is working


#10

and it does not work…


#11

all it does is says devices not ready for wifi


#12

wait a minute! DUDE THE INTERNET IS WORKING BUT IT SHOWS THAT IS ISNT LOL


#13

Screenshot_2019-02-04_17-00-02


#14

yo can you help me? I reinstalled Manjaro
boot/efi, root, swap on ssd (sdb)
and /home on sda1 hdd terrabyte

i installed local package Broadcom-wl but the wifi won’t work. basicaly I am back to step one.


#15

If your wifi is not connecting immediately after start up this is likely to correct it:

Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.


#16

thank you for your swift reply. tbg you’re awesome man.
the thing is, there is no menu to click for wifi settings. It’s as if the wifi menu does not exist.
for example: I click on the left bottom corner (network settings) and al i see is “Ethernet Network > Disconnected” and “Add VPN connection.” What driver should I locally install so that my wireless interface can work and then detect wifi?


#17

If you install the broadocom-wl_dkms driver from the AUR then you also need to install the Linux headers for your kernel.

If you installed kernel 4.20, then you also need to install linux420-headers. The number must match your kernel version.

Questions you need to answer:

Which driver did you install?

Which kernel did you install?


#18

so i installed this broadcom: https://aur.archlinux.org/packages/broadcom-wl-ck/

and as for kernel i dont know much, but what i could tell you is i just did an offline install of Manajro XFCE… hey man i feel like i am bugging you if anything… ill just reinstall everything with ethernet and just download the drivers needed via package manager after update… but anyways… thank you i appreciate it and your patience


#19

That is not the correct driver. That is a driver for a special kernel version. Uninstall it and see if you can get a connection with the built in kernel modules. Make sure there are no blacklists for the broadcom driver modules left in /etc/modprobe.d after you delete that driver then reboot.


#20

may a moderator please delete this forum?

I installed Manjaro with ethernet and i installed linux419 headers with the Broadcom driver in package manager and it works now. Thank you.