[Solved] White screen "Oh no! something has gone wrong" after interrupted update

Today I ran on my dualboot Windows7/Manjaro system the usual update ‘sudo pacman -Syu’, starting a system update.
While doing so, my pc froze (this happens from time to time and must not be necessarily be connected to my problem), so I hit the restart button.

After doing so, my system failed to boot, giving me

error: file ‘/boot/vmlinuz-5.8-x86_64’ not found,
error: you need to load the kernel first.

which I could solve by installing the newest kernels (and nvidia-drivers) with chroot

Now however I’m stuck when logging in, where only a white screen with a sad smiley and the text:
“Oh no! Something has gone wrong”

I can log into TTY and already tried

  • disabling all gnome-extensions
  • Checking my partitions with gparted

I then tried following an archlinux-forum post, suggesting to take a look at the journal of the last boot, the pacman.log and the Xorg.1.log, however, as I am not really experienced with troubleshooting, I do not know what to look for in the logs and even if I did find anythin, I would probably not know how to resolve it.

So maybe someone has either

  • another approach how to solve this problem.
  • the skills, the time and the will to take a look at my logs: (I wanted to put links to the logs here, but as I am only TL0, this is not possible).

Every bit of help is much appreciated!

PS: I tried to match everything I tried with a corresponding link to a forum, however, since I am only TL0, I was not allowed to add any links, which makes this a bit harder to document - sorry for the inconvenience.

Try running sudo pacman -Syu there.

I already did that during fixing the the first error, since this was also my first idea to try resolving the issue, since finishing the update is the most sensible step on a failed update.

This was mentioned in one of the links I planned to put in, but failed then to mention it after removing the links.

I’ve started to work my way more through the logs and first I tried to see, at which point the update got interupted - from the pacman.log I see that I restarted while installing yay (as one can see from the corrupted line, after which I ran pacman -Syy, marking th beginning of my debugging.

[2020-11-05T13:53:17+0100] [ALPM] upgraded yarn (1.22.5-1 -> 1.22.10-1)
[2020-11-05T13:53:17+0100] [ALPM] upgraded yay (10.0.4-1 -> 10.1.0-2)
��������������������������������������������������������[2020-11-05T15:04:16+0100] [PACMAN] Running 'pacman -Syy'
[2020-11-05T15:04:16+0100] [PACMAN] synchronizing package lists
[2020-11-05T15:04:35+0100] [PACMAN] Running 'pacman -Syu'

PS: As I should have mentioned, I running the gnome version of Manjaro and instead of the loginscreen of gnome, I am greeted with the error-message.

I now found a way to fix the problem. I reinstalled gnome-shell, gnome-session, gdm3, which is such an obvious solution. The login now functions without problems.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.