SOLVED: Use of Grub in ARM Manjaro on Raspberry Pi 4B

In a post on the forum from 2022, dealing with restoring a root password, based around GRUB, one post includes the statement that GRUB is not yet included in ARM. I need to reset a root password which, despite frequent use, is now lost in the mists of post-COVID brain fog, and on looking into the package list in Add/Remove Software on the Pi, I find that GRUB is indeed listed, but not installed. So, my first question is, will installing GRUB on my current OS (uname gives: Linux Rpi 6.1.69-1-MANJARO-RPI4 #1 SMP PREEMPT Thu Dec 21 16:01:20 UTC 2023 aarch64 GNU/Linux) with KDE break the OS? Next question, If it won’t break the system, and I instal it, how do I boot to the GRUB menu?


You can’t. Grub will not work, but the system will not break just because you installed it. But it is a very bad idea.

Just reflash and restore your settings and files form your backup. Side note, if you can install packages with sudo, you are able to be root and you can change the root password. Also, you can just mount the filesystem on a different system and change all files, which means you can change the root password hash.

Booting an ARM device is quite different from x85 bios or efi. I don’t even know the difference - you may be more knowledgeable.

While I cannot say it is not possible it is completely unnecessary

installing GRUB on your ARM based Manjaro is not advisable and it is very complicated to boot the process.

Thanks to all who participated in this thread. However, the problem has now gone away, as my post-COVID brain fog has cleared a little, and my user password has come back to me! So, result, and to be on the safe side I’ve reset the root password using sudo (which worked) and all is well. I’ve also noted the two passwords in coded form in a secure location!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.