[Solved] Update fails at modprobe error, system hangs, won't boot

While updating I eventually get the following output and error:

(12/31) Updating linux initicpios…
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: ‘default’
→ -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64.img
==> Starting build: 4.14.221-1-MANJARO
→ Running build hook: [base]
→ Running build hook: [udev]
→ Running build hook: [autodetect]
modprobe: ERROR: missing parameters. See -h

After this the system becomes unresponsive and is eventually frozen. I can’t switch to TTY with ctrl+alt+F1-F7.
When I hard shut down the computer and try to reboot I get:

error: file `/boot/initramfs-5.4-x86_64.img’ not found
Press any key to continue…_

Nothing happens when I press any keys. Switching to TTY also doesn’t work.
If I chroot into my system, what can I do to diagnose and repair this issue?

FYI, this also happened when I tried to update last week as well, but I didn’t have time to fully address the problem, so I delayed by simply restoring a timeshift backup with another linux partition.

see this

1 Like

Wonderful. I followed those steps replacing 5.7 for 4.14 in my case.

sudo manjaro-chroot -a
ls /etc/mkinitcpio.d/*.preset
mhwd-kernel -li
rm /etc/mkinitcpio.d/.preset
mkinitcpio -P

Problem solved, thank you very much

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.