[Solved] R7 7840H cannot boot to desktop with 6.6.7-4 kernel

Update: Kernel 6.6.8-2 solved this issue.

Hi, after upgrading my manjaro kernel from 6.5.13-6 to 6.6.7-4, it fails to boot into the KDE desktop (black screen after HP’s logo). I cannot switch to other tty. REISUB can be used to reboot.

Also, I’ve downloaded the newest manjaro-kde-23.1.0-minimal-231215-linux66.iso but it cannot boot into the KDE desktop neither with open source driver nor with property driver.

The previous kernel 6.5.13-6 works well. Could the settings from 6.5.13-6 be affecting the ability to switch to another GPU driver in 6.6.7-4? If not, what steps should I take to resolve this issue?

I will provide more system information later. Thank you for your help!

mhwd --listinstalled

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

inxi --admin --verbosity=7 --filter --no-host --width:

  Kernel: 6.5.13-6-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=6e72d55a-a1a4-4842-a22e-b80f8168dddb rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Plus Laptop 14-ey0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 8C21 v: 87.27 serial: <superuser required> UEFI: Insyde
    v: F.02 date: 08/10/2023
  ID-1: BAT0 charge: 67.6 Wh (100.0%) condition: 67.6/67.8 Wh (99.7%)
    volts: 8.7 min: 7.7 model: 333-CF-18-A WE04068XL type: Li-ion
    serial: <filter> status: full cycles: 1
  System RAM: total: 32 GiB note: est. available: 30.56 GiB
    used: 3.39 GiB (11.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 7840H w/ Radeon 780M Graphics bits: 64 type: MT MCP
    arch: Zen 4 gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
    family: 0x19 (25) model-id: 0x74 (116) stepping: 1 microcode: 0xA704103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 400 min/max: 400/5764:6080:5924:5608:5137:5449:5293
    scaling: driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400
    3: 400 4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 bogomips: 121432
  Flags: 3dnowprefetch abm adx aes amd_lbr_v2 aperfmperf apic arat avx avx2
    avx512_bf16 avx512_bitalg avx512_vbmi2 avx512_vnni avx512_vpopcntdq
    avx512bw avx512cd avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flush_l1d flushbyasid fma fpu fsgsbase fxsr fxsr_opt gfni
    ht hw_pstate ibpb ibrs ibrs_enhanced ibs invpcid irperf lahf_lm lbrv lm
    mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx
    nonstop_tsc nopl npt nrip_save nx ospke osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    perfmon_v2 pfthreshold pge pku pni popcnt pse pse36 rapl rdpid rdpru
    rdrand rdseed rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep ssbd
    sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
    topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vaes vgif
    vmcb_clean vme vmmcall vnmi vpclmulqdq wbnoinvd wdt x2apic x2avic xgetbv1
    xsave xsavec xsaveerptr xsaveopt xsaves
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Phoenix1 vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: RDNA-3 code: Phoenix process: TSMC n4 (4nm) built: 2023+ pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1, DP-2, DP-3,
    DP-4, DP-5, DP-6, HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15bf
    class-ID: 0300 temp: 30.0 C
  Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision 5MP Camera
    driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 3-1:2 chip-ID: 05c8:0831 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: Samsung 0x4197 built: 2022 res: 2880x1800 dpi: 242
    gamma: 1.2 size: 302x189mm (11.89x7.44") diag: 356mm (14") ratio: 16:10
    modes: max: 2880x1800 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (gfx1103_r1 LLVM
    16.0.6 DRM 3.54 6.5.13-6-MANJARO) device-ID: 1002:15bf memory: 500 MiB
    unified: no
  API: Vulkan v: 1.3.269 layers: N/A device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV GFX1103_R1) driver: mesa radv v: 23.1.9-manjaro1.1
    device-ID: 1002:15bf surfaces: xcb,xlib
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_ps v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.13-6-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 01:00.0
    chip-ID: 14c3:0616 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 0e8d:223c
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 28.28 GiB (3.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL41T0HBLB-00BH1
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS3NHAV temp: 28.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 507.81 GiB size: 498.77 GiB (98.22%) used: 28.22 GiB (5.7%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: 6e72d55a-a1a4-4842-a22e-b80f8168dddb
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 58.4 MiB (22.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: A0D4-0B99
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 445.09 GiB fs: ntfs
    label: Windows uuid: 00FE4EF9FE4EE70E
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 705 MiB fs: ntfs
    label: Windows RE tools uuid: E00CD3400CD31080
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 5 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-5:2 info: MediaTek Wireless_Device type: bluetooth
    driver: btusb interfaces: 3 rev: 2.1 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 100mA chip-ID: 0e8d:223c class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-1:2 info: Cheng Uei Precision Industry (Foxlink) HP Wide
    Vision 5MP Camera type: video driver: uvcvideo interfaces: 5 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 500mA
    chip-ID: 05c8:0831 class-ID: fe01 serial: <filter>
  Hub-4: 4-0:1 info: super-speed hub ports: 1 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-5: 5-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-6: 6-0:1 info: super-speed hub ports: 1 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-7: 7-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-8: 8-0:1 info: super-speed hub ports: 1 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 35.1 C mobo: N/A gpu: amdgpu temp: 31.0 C
  Fan Speeds (rpm): fan-1: 0 fan-2: 0
  Processes: 377 Uptime: 24m wakeups: 1 Init: systemd v: 254 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman
  pkgs: 1324 libs: 345 tools: pamac,yay Shell: Zsh v: 5.9 default: Bash
  v: 5.2.21 running-in: konsole inxi: 3.3.31

Stay away from 6.6 series for now, as 6.5 is also EOL, you might want to go back to 6.1 as the previous LTS. Unless you’re willing to stay on that EOL kernel, though it might impose package versioning problem sooner or later.

You might want to check for any lines marked EE in /var/log/Xorg.0.log[.old], as well as:

$ sudo systemctl status sddm

as it’s the one responsible for booting up the graphical session.

1 Like

Considering the newness of the hardware I would suggest as high kernel as possible.
6.6 would seem like a reasonable choice, but if it is not working then I might try 6.7, even if it is rc.

1 Like

I didn’t try sudo systemctl status before because I couldn’t switch to tty with the new kernel, though some blogs mentioned sddm.

/var/log/Xorg.0.log.old can be checked in current kernel. It seems that GPU module loading has trouble:

[   134.831] (WW) AMDGPU(0): flip queue failed: Invalid argument
[   134.832] (WW) AMDGPU(0): Page flip failed: Invalid argument
[   135.059] (II) event3  - Video Bus: device removed
[   135.113] (II) event0  - Power Button: device removed
[   135.146] (II) event7  - ELAN07D0:00 04F3:321A Touchpad: device removed
[   135.247] (II) event6  - ELAN07D0:00 04F3:321A Mouse: device removed
[   135.306] (II) event2  - AT Translated Set 2 keyboard: device removed
[   135.336] (II) event5  - HP WMI hotkeys: device removed
[   135.414] (II) UnloadModule: "libinput"
[   135.414] (II) UnloadModule: "libinput"
[   135.415] (II) UnloadModule: "libinput"
[   135.415] (II) UnloadModule: "libinput"
[   135.415] (II) UnloadModule: "libinput"
[   135.415] (II) UnloadModule: "libinput"
[   135.416] (II) Server terminated successfully (0). Closing log file.

I’ll search for this next. Thanks for your advice!

I have the same oponion, and plan to do so if I fail to solve this problem.

As you mentioned, the previous kernel version (6.5.13-6) works well. You can use GRUB to boot into this older kernel for now until you find a solution. When booting, press Esc or a similar key to view detailed boot messages. Look for any error messages or warnings that might give you clues about what’s going wrong. Make sure your graphics drivers are compatible with the new kernel. If you were using proprietary drivers, you might need to reinstall or update them to match the kernel version. For open-source drivers, ensure that they are also up to date.

Interesting, my brother just got a new laptop from his work, and HP Z series, forget the model, but he tried the major Manjaro editions, XFCE, Plasma and Gnome and he said they all failed to boot into the Desktop as well. But his machine is an Intel based unit with Nvidia. I say this is because he wanted to know what I did to the DeLinuxCo to make it work, I said nothing, it’s just a spin of Manjaro, Cinnamon, it uses Kernel 6.6 and that is the only change.
If anyone here having their issue is willing to try I would like to know if it indeed does boot while the others do not?

Also, if you are able to get to a command line, try adding “amdgpu” to the initial ramdisk

edit /etc/mkinitcpio.conf

Add amdgpu to the modules array

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

Then run
sudo mkinitcpio -P

and reboot.

I modified /etc/mkinitcpio.conf and generate new initramfs-fallback.img. It failed to boot into desktop with the “6.6.7-4 (fallback initramfs)” option in GRUB.
But Xorg.0.log.old is different, without “failed” words.

@aijizhilv maybe try to boot into linux67 and see if the upcoming kernel of 2024 fixes your issues. Else keep 6.5 running. Normally we will maintain that one for another month or so.

6.7.0-rc6-1 (Experimetal) can boot to desktop, but it comes with severe screen flickering issues. I’ve given up on try with new kernel, and have confirmed that 6.1 LTS works fine, which can be an alternative kernel after EOL of 6.5.13-6.

I’ll mark this issue as solved once 6.6 LTS or later version can successfully boot to desktop. Thanks to everyone who has provided suggestions in this thread!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.