[solved] No partitions detected by Manjaro installer


I have quite the same problem. I want to install Manjaro Gnome 20.2.1 following this instruction:

However I get the same error as @wafelack. The installer doesn’t recognize the empty partition I created beforehand.

Considering the checklist you posted, @megavolt, I’d like to ask if the following warning, which I get when selecting AHCI instead of RAID ON in my BIOS, can be ignored:

“Changing this setting may prevent your OS from booting or require a reinstall …
The E-Module and other eSATA devices only function in AHCI or Raid On mode”

Also in my BIOS I can only set Fast Boot to “minimal” or “thorough” (I think thorough meaning a thorough = longer startup).

@rogerR, Fast Startup is meant here I guess which needs to be disabled in Windoze.

@Wollie: Oh thx. I know that there’s also one in Windoze and that’s disabled.

I’m wondering if changing from AHCI to RAID ON would help, but I don’t know, if it will leave my system intact.

Hi, I guess it should still be mostly accurate, but it’s a tutorial from 2019… Rolling releases like Manjaro roll fast.
Better use the infos directly from the source, as the link @Wollie posted above.

Moreover, was the parition created within Windows or within Manjaro installer environment? I’d rather modify my partition here (With Gparted by example or directly through the installer), in ext4 format, format Windows does not recognize by the way.

Oh thanks I didn’t check out that post by @Wollie before. Looks very helpful. It mentions shrinking the partition in Windows, which is how I did it.

I’m wondering if changing to AHCI instead of RAID ON will help, but I can’t be sure that the system will still run afterwards, as there’s a warning which I posted above.

Switching to AHCI did it. I followed a proposal how to do it, which involved starting MSCONFIG, activating Safe boot (minimal), rebooting into BIOS UEFI (?), selecting AHCI, next Boot up was Safe Mode - there: starting MSCONFIG, deactivating Safe boot (minimal), restart.

I think that’s how I did it.