[Solved] My wifi has split into 4, and it's pretty slow at that

Hello everyone. I’ve been having some issues with the wifi on Manjaro lately. I’ve tried upgrading and downgrading the kernel from 5.8 to 5.10 to 5.9 and there has been no improvement, so that’s not the issue. Right now my wifi looks like this in the network-manager applet:

As you can see my wifi has split in two… twice! And the connection is fairly unreliable too.

Inxi -F returns

 System:    Host: sentientcatAI Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81W0 v: IdeaPad 3 14ADA05 serial: <superuser required> 
       Mobo: LENOVO model: LNVNB161216 v: SDK0R32891WIN serial: <superuser required> UEFI: LENOVO v: E8CN21WW 
       date: 05/29/2020 
Battery:   ID-1: BAT0 charge: 30.1 Wh condition: 31.6/35.3 Wh (89%) 
CPU:       Info: Dual Core model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 type: MT MCP L2 cache: 1024 KiB 
       Speed: 1395 MHz min/max: 1400/2600 MHz Core speeds (MHz): 1: 1395 2: 1395 3: 1393 4: 1392 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
       Device-2: Syntek Integrated Camera type: USB driver: uvcvideo 
       Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
       OpenGL: renderer: AMD Radeon Vega 3 Graphics (RAVEN2 DRM 3.39.0 5.9.16-1-MANJARO LLVM 11.0.1) v: 4.6 Mesa 20.3.4 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
       Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
       Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
       Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter driver: rtl88x2ce 
       IF: wlan1 state: up mac: 2a:cd:c4:50:d9:09 
       IF-ID-1: wlp2s0 state: down mac: f2:63:60:d0:70:bb 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb 
       Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 119.24 GiB used: 65.46 GiB (54.9%) 
       ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZMT128G MEMORY size: 119.24 GiB 
Partition: ID-1: / size: 81.26 GiB used: 65.43 GiB (80.5%) fs: ext4 dev: /dev/nvme0n1p5 
       ID-2: /boot/efi size: 256 MiB used: 28.5 MiB (11.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 64.8 C mobo: N/A gpu: amdgpu temp: 64.0 C 
       Fan Speeds (RPM): N/A 
Info:      Processes: 312 Uptime: 1d 15h 43m Memory: 17.52 GiB used: 10.25 GiB (58.5%) Shell: Bash inxi: 3.3.01 

This driver is pretty unreliable, and before I modprobed 88x2ce my wifi used to drop every 20 minutes for about 2-3 minutes. I’ve not been able to install any other modules or probes on my copy of Manjaro.

Any ideas? Please tell me if there’s any more information I need to provide.


I’d delete all four of the “Cecilie” connections and then add a new connection to that Network.
just to clean things up …

It’s strange that you seem to have two wlan interfaces:
wlan1 and wlp2s0
With the currently active driver rtl88x2ce that interface is called wlan1

I wonder where the wlp2s0 interface comes from.
Is it different hardware? - if has got a different MAC.
But that could be due to MAC randomization done by NetworkManager.
Don’t know.

You mentioned:

You seem to use two different drivers/use two separate wlan-adapters?
If that is so:
blacklist one of them
so that only the one you want/need is loaded.

When I run dkms-status I get

> rtl8812au,, 4.14.221-1-MANJARO, x86_64: installed
rtl8812au,, 4.4.257-1-MANJARO, x86_64: installed
rtl8812au,, 5.10.15-1-MANJARO, x86_64: installed
rtl8812au,, 5.9.16-1-MANJARO, x86_64: installed
rtl8821ce, v5.5.2_34066.20200325, 4.14.221-1-MANJARO, x86_64: installed
rtl8821ce, v5.5.2_34066.20200325, 4.4.257-1-MANJARO, x86_64: installed
rtl8821ce, v5.5.2_34066.20200325, 5.10.15-1-MANJARO, x86_64: installed
rtl8821ce, v5.5.2_34066.20200325, 5.9.16-1-MANJARO, x86_64: installed
rtl88x2ce, 35403, 4.14.221-1-MANJARO, x86_64: built
rtl88x2ce, 35403, 4.4.257-1-MANJARO, x86_64: built
rtl88x2ce, 35403, 5.10.15-1-MANJARO, x86_64: installed
rtl88x2ce, 35403, 5.9.16-1-MANJARO, x86_64: installed
rtw88, r51.c3bdd9f, 5.10.15-1-MANJARO, x86_64: installed
rtw88, r51.c3bdd9f, 5.9.16-1-MANJARO, x86_64: installed

so it seems several modules have been installed for the same Realtek wifi chip, how do I blacklist?

Here is a file I have (and probably you, too)

it’s contents are:

# blacklist the speaker module to stop beeps
blacklist pcspkr

simply list the module by name in a file with a descriptive name ending with .conf in that directory

but before, check that this is even the issue that is causing your problem
lsmod | grep rtl88
check whether both are even loaded

after reboot verify that only one is present

simply deinstall one of the two packages providing different versions of the module …

$ lsmod | grep rtl88

rtl88x2ce 3051520 0
cfg80211 913408 3 rtl88x2ce,rtw_core,mac80211

Seems like only rtl88x2ce is loaded, weird, why is my wifi split in two then? The connection has also dropped til mere nonexistence, I can barely play watch youtube videos anymore :confused: Idk if you know but any pointers would be helpful.

I used journalctl -f to document the network manager log while trying to connect to the wifi after deleting all the connections and if I connect to wlan0 or wlp2s0 the program ends up spamming

RTW: _alloc_mgtxmitframe(wlan0) alloc xmitbuf fail

and the wifi refuses to connect, on wlp2s0 it ends up saying no secrets have been provided. Really confusing issue so far, I’ve been struggling with this wifi card for a while now. Posting this through mobile tethering :sweat_smile: Going to try rebooting to see if it at least brings my poopy near-unusable wifi back for a moment.

I’d remove/deinstall the module that you now still have but don’t intend to use.
you have these two

one is not used, not even loaded
if I have problems, I start eliminating possible factors.

You earlier said … you modprobed it …
yet, the network seemed to have at least somehow worked before that/without that module loaded
from what you described …
This is all unclear to me.

Can you be sure that this is the right module and it is supposed to be working with your card?

why is my wifi split in two then?

Is it?
To me it looks like you have two entries because you used two different drivers.
One is old, the other newer …
Delete all of the connections and create a new one.

Someone else might be more knowledgable than me.

it appears that this driver
should work
You should only need to use the dkms built driver
if you use non-standard kernels

perhaps installing an LTS kernel and using that - or a 5.10 or 5.11 kernel - will give different results.

I have no way of removing these, neither pacman -R not pamac remove can find them.

My network has been having issues for a while now. The rtl88x2ce driver has subpar performance so I’ve been trying to change it to rtw88 or something similar, but I haven’t been able to do so. The latest consequence was the splitting of the wifi into wlan1 and wlp2s0.

I don’t know how :sweat:

I’ve tried deleting the connections but it still appears as two separate wifi connections, wlan1 and wlp2s0 even when I’m not connected to it.

I can try installing rtw88, but to avoid conflict I need to uninstall rtl88x2ce, which I don’t know how to either, as again, neither pacman -R or pamac remove can find it. Do you know how I could find out what package the driver is installed with for removal?

Update! I managed to merge the two wifis back using the instructions for rtw88 here GitHub - lwfinger/rtw88 and blacklisting rtl88x2ce and the other conflicting drivers. Idk if my wifi has been improved but now we’re at least back to somewhere legible, thanks for the help Nachlese :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.