[Solved] Manjaro KDE: Unable to boot to desktop screen

Hello fellow forum members!

Hope things are good at your end.

I have an issue with my Manjaro not booting up properly. Here are the details:

Manjaro KDE is installed on a separate SSD. Latest updates & kernel.

Was working an hour ago. And I had to do a reboot and I cant get to the desktop screen anymore.

I can see the GRUB menu, allows me to choose from;
Advanced Options
Windows 10
Memory Tester +86

But when I choose ‘Manjaro’ I just see a blank cursor on my screen and it just stays there. Typically, the taskbar, desktop loads immediately. Now that’s not happening.

I am certain that the / partition got full as I was installing all sorts of stuff. I really want to avoid a format/reinstall.

There must be a single user/rescue mode through I can at least get to cli from where I can empty .cache related stuff and attempt a normal boot.

I tried to boot through a live USB, it boots but the partition manager does not read any sde devices so that I was hoping to add additional space to / and get things rolling.

Any help in this matter would be highly appreciated.


First of all, welcome at the forum, @trooper !

This is not good news. I would try to boot again into live iso and open a terminal window to enter:

sudo parted -l
sudo fdisk -l
sudo blkid
lsblk -f

Let’s hope to get your ssd being detected.Please, post the output here.

1 Like

Hi Wollie,

Thanks for replying and thank you for the welcome!

Below are the results you’ve requested for:

sudo parted -l
Model: ATA SPCC Solid State (scsi)
Disk /dev/sde: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type      File system  Flags
 2      64.5kB  256GB  256GB   extended               lba
 5      2097kB  114GB  114GB   logical   ntfs
 7      114GB   147GB  33.2GB  logical   ext4
 6      147GB   256GB  109GB   logical   ext4

Model: SanDisk Ultra (scsi)
Disk /dev/sdg: 15.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15.6GB  15.6GB  primary  fat32        boot, lba

The /dev/sde is where my Manjaro resides. There are other hard disks too, but those are non-boot and ntfs ones. It would clutter the reply-space, hence I did not add that.

sudo fdisk -l
Disk /dev/sde: 238.49 GiB, 256060514304 bytes, 500118192 sectors
Disk model: SPCC Solid State
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7b01be1d

Device Boot Start End Sectors Size Id Type
/dev/sde2 126 500117503 500117378 238.5G f W95 Ext’d (LBA)
/dev/sde5 4096 222062591 222058496 105.9G 7 HPFS/NTFS/exFAT
/dev/sde6 286965760 500117503 213151744 101.7G 83 Linux
/dev/sde7 222064640 286963711 64899072 31G 83 Linux

Partition table entries are not in disk order.

sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/loop1: TYPE=“squashfs”
/dev/loop2: TYPE=“squashfs”
/dev/loop3: TYPE=“squashfs”

/dev/sde5: LABEL=“Xtended-NTFS” BLOCK_SIZE=“512” UUID=“01D4EBDA6607EBA0” TYPE=“ntfs” PARTUUID=“7b01be1d-05”

/dev/sde6: LABEL=“EXT-storage” UUID=“98769931-253e-47c7-8160-7dfe9e860b7c”
BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“7b01be1d-06”

/dev/sde7: UUID=“90cce850-ec5a-42d7-87df-5c542cad63e2” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“7b01be1d-07”

lsblk -f
loop0 squashfs 4.0 0 100% /run/miso/sfs/livefs
loop1 squashfs 4.0 0 100% /run/miso/sfs/mhwdfs
loop2 squashfs 4.0 0 100% /run/miso/sfs/desktop
loop3 squashfs 4.0 0 100% /run/miso/sfs/rootfs

├─sde5 ntfs Xtended-NTFS 01D4EBDA6607EBA0
├─sde6 ext4 1.0 EXT-storage 98769931-253e-47c7-8160-7dfe9e860b7c
└─sde7 ext4 1.0 90cce850-ec5a-42d7-87df-5c542cad63e2

Those are the details you requested for.

Also, I would like to know if there are any runlevel options that I can try. If there’s any parameter that I may add to the boot options on GRUB with ‘e’.

One more thing, if anyone could let me know, for the MNJ KDE-Plasma variant, which directory holds the user-based customization settings; e.g - Taskbar customisations, Fonts, Global & Plasma themes, Icons etc. Which directory(s) stores these?


So, good news is that your sde is detected by all tools normally.

If you boot an USB stick I would expect that you could chroot into your system by opening a terminal window and enter

sudo manjaro-chroot -a

(select 1 if only one system is offered)

Then run

pacman -Sc

This cleans your package cache.


pacman-mirrors -f && pacman -Syyu

and try to reboot normally.

All your settings are located in


Thanks for the lightning fast reply!!

I’ll try the steps you’ve mentioned.

In my initial post, what I meant by ‘does not read any sde devices’, I was referring to the default partition manager that comes with the Live boot. Sorry for the confusion from my side.

Wollie, I’ve got great news for you and for myself too.

I am now replying to you from my daily-Manjaro system. yay! Thanks to all of your timely responses.

I booted through the Live media. Initiated chroot via terminal, which in turn mounted the / FS of my MNJ. I exactly knew which cache was consuming the buffer space required by the system to mount / in order for me to boot to Manjaro. Through the chroot mode, I deleted the ~/ ‘Steam cache’ that was taking up the essential space and rebooted normally.

chroot mode was what I’d looked for. At the moment, I’m not going to the perform the additional steps you’ve mentioned after the ‘chroot’ point, however, I’ve made a note of all the things it in case such an emergency occurs in the future. I’ll also be increasing the / partition space.

All Linux community forums rule! But Manjaro community is something very special.

Have a Nice Day folks!

1 Like

So, I’m suspecting something. This is round 3 for me installing Majaro on this HP Stream with Intel N3060 on it, as I rolled through updated the 2nd time around, found that the Intel Microcode Library was removed due to conflicts.
I initially thought, “Well, that must mean there’s a new update for it.” Seems like that isn’t the case. I’ll reply again with which update library has the conflict.

Appears the most recent installer for XFCE Manjaro is shipping with a not supported kernel. Will update with any news.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.