[SOLVED] Libre Office Writer can't start after last system update

update
openrc
manjaro
libreoffice

#1

I have manjaro OpenRC.

I updated my system and then Libre Office Writer can’t start.
Other office programs start with no problems.
I reinstal Office with libreoffice-fresh-5.3.4-1, but problem is not solved.


#2

Many people have had this issue. Disabling JRE solves it. See here:


#3

Thanks. I didn’t find this topic. Solved!


#4

Tangentially …

I too am running OpenRC and libreoffice-fresh-5.3.4-1, and knew (but had forgotten about) the disabling Java trick. LO Writer was working for me, over the past few months, but oftentimes it would open with a broken window stretching past the top of the desktop.

Unchecking JRE appears to have fixed this bug as well.


#5

Thanks so much! I’m not a Linux expert in any way, and after trying several kernel versions the same problem persisted. Disabling JRE did it for me. Now I can finish setting up a client’s system who wants to try Linux - not good if the Word Processor sulks and disappears, even when Writer is started from opening her own docx files.


#6

Its’ a pity I don’t understand how to make it… Where or when should I turn the (alt F12 ) Options to proceeed with the JRE unchecking? Please explain for me, a simple user.
thx


#7

I believe only LibreOffice Writer crashes, right? Try starting LibreOffice Calc and going to Options (Alt-F12), under Advanced, to disable JRE.


#8
  1. Open LibreOffice
  2. Press ALT+F12 or go to Tools, Options… via the menu.
  3. Go to LibreOffice->Advanced, and untick ‘Use a Java runtime environment’

The original instructions are pretty clear, but hopefully these are unambiguous.


#9

Thankyou Both. But now even any of the LibreOffice segements doesn’t open. No Calc, no Draw either…


#10

You mean they don’t open before you disabled JRE, or after you did that?


#11

Yes. But now I’ve removed/reinstalled the whole LO once, twice, plus octopi washed the cash and I have Calc fired up. JRE unchecked, and LO Writer jetted on screen.
So, thankyou friends.


closed #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.