[solved] Launching software updater failed

New to manjaro but not kde. New installation, updated using software updater. Rebooted into my normal OS and re saved grub to mbr. Rebooted back into Manjaro. Tried the software updater and the add/remove menu item and they both gave me the same error as the subject.
I also tried using the command line as in (sudo pacman -Syu). Command line gave me the message that I was up to date. Rebooted again into Manjaro and still get the same error when trying to use software updater or the add/remove menu items.
What do I need to do?

Which is? Discover, maybe?

That would be Pamac. To be clear, what you’re calling software updater is different from the add/remove menu item?

What error? You haven’t told us what the error was yet. Failed doesn’t tell us anything.

This is what the error says.
Unable to make the service Software Update executable, aborting execution.
No such file or directory.
It launches from the tray but not from the menu. Guess I will have to edit the menu item.

It seems that it is working again.