[SOLVED] - [Intel AX200] Wireless issue after install

I've just installed Manjaro on a new machine.
The laptop has an Intel AX200 wireless card.
The driver appears to be installed and active:

$ hwinfo --netcard --bluetooth | grep -v "Config S"
10: PCI 200.0: 0280 Network controller
  [Created at pci.386]
  Unique ID: B35A.o_xLA3Zg0GC
  Parent ID: qTvu.3Hs7LBkF+a5
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Intel Network controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2723 
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x0084 
  Revision: 0x1a
  Memory Range: 0xd5300000-0xd5303fff (rw,non-prefetchable)
  IRQ: 17 (no events)
  Module Alias: "pci:v00008086d00002723sv00008086sd00000084bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Attached to: #20 (PCI bridge)

33: USB 00.1: 11500 Bluetooth Device
  [Created at usb.122]
  Unique ID: xnLL.qmlouffvxgF
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1
  SysFS BusID: 1-4:1.1
  Hardware Class: bluetooth
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x8087 "Intel Corp."
  Device: usb 0x0029 
  Revision: "0.01"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v8087p0029d0001dcE0dsc01dp01icE0isc01ip01in01"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Attached to: #39 (Hub)

interface is not turned off (there is no wireless toggle button on this machine):

$ rfkill list
0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

The interface is simply not there:

$ ifconfig
enp0s20f0u2c4i2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.20.10.4  netmask 255.255.255.240  broadcast 172.20.10.15
        inet6 fe80::3380:718f:ced1:365  prefixlen 64  scopeid 0x20<link>
        ether d2:2b:20:f1:95:c2  txqueuelen 1000  (Ethernet)
        RX packets 342697  bytes 438666999 (418.3 MiB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 173512  bytes 11657448 (11.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

system info (curiously, inxi doesn't see the driver):

$ inxi -Fxxxz
System:    Host: nak Kernel: 5.3.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: Prestige 15 A10SC v: REV:1.0 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Micro-Star model: MS-16S3 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16S3IMS.106 
           date: 09/09/2019 
Battery:   ID-1: BAT1 charge: 16.1 Wh condition: 81.0/80.3 Wh (101%) volts: 14.7/15.2 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Unknown 
CPU:       Topology: 6-Core model: Intel Core i7-10710U bits: 64 type: MT MCP arch: N/A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38415 
           Speed: 400 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400 8: 400 
           9: 400 10: 400 11: 400 12: 400 
Graphics:  Device-1: Intel vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bca 
           Device-2: NVIDIA driver: N/A bus ID: 03:00.0 chip ID: 10de:1f91 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2) v: 4.5 Mesa 19.2.6 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.3.12-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: N/A port: efa0 bus ID: 02:00.0 chip ID: 8086:2723 
           IF-ID-1: enp0s20f0u2c4i2 state: up speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 7.65 GiB (1.6%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1032 size: 476.94 GiB speed: 15.8 Gb/s 
           lanes: 2 serial: <filter> rev: 20140000 scheme: GPT 
Partition: ID-1: / size: 109.90 GiB used: 7.51 GiB (6.8%) fs: ext4 dev: /dev/nvme0n1p6 
           ID-2: /home size: 154.87 GiB used: 114.2 MiB (0.1%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-3: swap-1 size: 19.53 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p8 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 247 Uptime: 39m Memory: 15.48 GiB used: 1.48 GiB (9.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.36 

strange thing powertop shows the interface up and running:

Power est.    Usage     Device name
  4.29 W     18.4%        CPU misc
  764 mW     18.4%        CPU core
            100.0%        Audio codec hwC0D0: Realtek
  394 mW     18.4%        DRAM
    0 mW    100.0%        Display backlight
            100.0%        PCI Device: Intel Corporation Device 9bca
            100.0%        PCI Device: Intel Corporation Wi-Fi 6 AX200

One more thing. I've installed a RebornOs instance right before this install and the wireless connection was available without any intervention(I've overwritten RebornOS with Manjaro). This tells me that it is not a hardware or inexisting drivers issue.

Also now that I think about it I remember I had the same issue on my old machine with a totally different wireless card when I tried out Manjaro 2 years ago. It was the reason I didn't stick with Manjaro and searched for alternate Arch based distros. The wireless connection had no issues on other distros, but Manjaro was simply not able to detect the card. In the meantime I'm a bit more inclined to debug and sort out issues, so I'd like to give it a go and try to troubleshoot the thing before I move to other distros.

Not saying this will or will not help, and it involves waiting unless you want to build your own package...

There is new linux firmware for the ax200.

Hmm the driver for this card is iwlwifi-cc-046 as per Intel's website

grab the latest firmware from intel an follow intels setup instructions. i'm not seeing it in the latest firmware here on arch so i doubt you have it on manjaro

filename:       /lib/modules/5.3.13-zen1-1-zen/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko.xz
license:        GPL
author:         Copyright(c) 2003- 2015 Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-6.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-6.ucode
firmware:       iwlwifi-7265D-29.ucode
firmware:       iwlwifi-7265-17.ucode
firmware:       iwlwifi-3168-29.ucode
firmware:       iwlwifi-3160-17.ucode
firmware:       iwlwifi-7260-17.ucode
firmware:       iwlwifi-8265-36.ucode
firmware:       iwlwifi-8000C-36.ucode
firmware:       iwlwifi-9260-th-b0-jf-b0-46.ucode
firmware:       iwlwifi-9000-pu-b0-jf-b0-46.ucode
firmware:       iwlwifi-ty-a0-gf-a0-48.ucode
firmware:       iwlwifi-so-a0-gf-a0-48.ucode
firmware:       iwlwifi-so-a0-hr-b0-48.ucode
firmware:       iwlwifi-so-a0-jf-b0-48.ucode
####
firmware:       iwlwifi-cc-a0-48.ucode            <<<-------------
####
firmware:       iwlwifi-QuQnj-b0-jf-b0-48.ucode
firmware:       iwlwifi-QuZ-a0-jf-b0-48.ucode
firmware:       iwlwifi-QuZ-a0-hr-b0-48.ucode
firmware:       iwlwifi-Qu-b0-jf-b0-48.ucode
firmware:       iwlwifi-Qu-c0-hr-b0-48.ucode
firmware:       iwlwifi-QuQnj-a0-hr-a0-48.ucode
firmware:       iwlwifi-QuQnj-b0-hr-b0-48.ucode
firmware:       iwlwifi-Qu-b0-hr-b0-48.ucode
firmware:       iwlwifi-QuQnj-f0-hr-a0-48.ucode
firmware:       iwlwifi-Qu-a0-jf-b0-48.ucode
firmware:       iwlwifi-Qu-a0-hr-a0-48.ucode
srcversion:     30D93FB038BD9247D91CE84

edit: nevermind, it is there. but as you mentioned the latest listed driver for that card is 46, not 48.
https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi/iwlwifi-cc-46.3cfab8da.0.tgz

replace this
/usr/lib/firmware/iwlwifi-cc-a0-48.ucode
with this from the above file
/usr/lib/firmware/iwlwifi-cc-a0-46.ucode

reboot and see if it works

i'm not really sure what i did. i installed and uninstalled kernels (i'm back to default kernel 5.3.12 now), thinking maybe the module is not compatible with the particular kernel. I also deleted all firmware files starting with iwlwifi except cc-46 and 48. I thought to myself it can't hurt since i'm not going to use this install on another machine, so I'll always only be interested in drivers for this particular card, and was thinking that maybe the wrong iwlwifi driver is being loaded.
Anyway, after calling it a day and starting the system anew the next day wireless was working.
Again no idea what exactly was the thing that solved the issue, but i guess i was just a reboot away from making it work.

1 Like

When I had this problem(also on Prestige 15), it turned out that windows kept the resource on shutdown. Had to turn off fast startup in windows.

1 Like

hmm... i was indeed testing dual boot with windows.
I will do more tests when I get the machine back to check if it's a Windows issue.

Windows can interfere with networking in Linux. A hard power down (removing all power sources) and resetting the bios to the factory defaults can help if Windows is interfering. Disabling LAR in Windows and Linux is also sometimes required on Windows dual boots.

Dual booting with Windows is inevitably going to cause problems at some point.

i've still not managed to find a way of doing this on windows. not for lack of trying either and even intel doesnt know how or they just wont tell me. fscking winblows :face_with_symbols_over_mouth:

1 Like

Oh I'm sure they know how, but you can't be allowing Windows users to actually have control of their own systems now can you? :face_vomiting:

das ist verbotten :grin:

1 Like

Forum kindly sponsored by