[Solved] I3 doesn't fill the entire screen



I just installed manjaro i3wm, everything works fine, but I can only work on a small part of my screen.

Here is my screen now.
I tried changing the display settings and it worked, it fits the screen but the resolution is lower and text on the screen is blury.

Thank you!


It looks like you have two monitor outputs overlaid.

Do you have two monitors?


Sorry, I forgot to mention that I am using an external monitor because my laptop monitor is broken. So my main monitor is the VGA one in this list, the other connected one (LVDS) is the laptop’s monitor (which is not working)


OK, so “disconnect” (option 5) the broken one. :slight_smile:


Thank you! That solves the problem!

Though, I coudn’t disconnect the monitor using the 5th option. That didn’t work for some reason.
What I had to do is use xrandr and execute the following to disable that broken display:

xrandr --output LVDS1 --off

So I added the following line to my .i3/config to execute the command on startup:

exec --no-startup-id "xrandr --output LVDS1 --off"