[SOLVED] How can I permanently change my keyboard layout?

Hi, I recently started using a Piinebook Pro which comes installed with Manjero. During the initial setup I made mistake and chose the UK keyboard layout when my machine actually has a US layout keyboard. This manifests itself most annoyingly when I press SHIFT + 2 expecting an @ and get a ".

I can change this by going into System Settings > Keyboard Settings and selecting English (US), though this change is reverted when ever I reboot. How can I make this change permanent, so when I reboot I always come back to the same keyboard layout.

I’ve also tried following some of the instructions on the Arch Keyboard Config article
https wiki [dot] archlinux [dot] org/index [dot] php/Linux_console/Keyboard_configuration

(^can’t include links because I’m a newb)

I’ve updated /etc/vconsole.conf

KEYMAP=us

But still no luck :frowning_face: Any and all help is appreciated :pray:

You can use localectl to set the keyboard layout or the configuration utility from the control panel - start with

localectl --help

Of course you need to run it as superuser - because it writes system files.

I assume you are using KDE Plasma, go to System Settings > Input Devices > tab Layouts and add the preferred layout. I had the same issue yesterday and this solved it :slight_smile:

2 Likes

That did it! Thanks so much!

1 Like

Did this solve the problem permanently? Does the setting survive reboots now?
I’m having issues with Xfce not keeping my settings after I reboot.

Yeah, updating through the UI as recommended solved my problem. The issue was that I was changing the Manjaro keyboard settings, though not the Input Devices > tab Layouts settings

Well, that’s at least “curious” to me because that’s the only way I’m seeing of changing these settings here on the Manjaro that I’m currently running.
How were you doing these changes before? Is there another method?

Thanks, I needed that!