[Solved] Help to change Rofi keybind

Hi there,

Using Manjaro Architect, I recently installed Manjaro with the awesome-wm version. I’m quite please and been adjusting the settings to my taste. No problems so far, but one thing I have not been able to figure out is how to change rofi launch keys. On the awesome rc file, the keybind for rofi is set to Crtl+Super+Esc, which is fine. However somewhere in the system the Super key alone also launches rofi, and I find this quite annoying. I would like to cancel that single Super keybind to rofi, so that only the default awesome-wm key combination can bring rofi up.
The thing is I cannot find or figure out how to do that. As I said there is nothing binding Super (Mod4) alone to launching rofi on the awesome rc.lua file. I’ve also checked through Menu>Settings>Keyboard>Application shortcuts to make sure there is no keybind there. I have not installed xbindkeys, and there is no ~/.Xmodmap file.
How can I change that? Where should I look? Will appreciate if someone knows where it is set and how to delete the binding, or at list point me to the possible directions to look at.
Thanks.

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

Thanks for the info. Here my inix output:

System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=7e8e3239-02fa-4590-bdbc-248074d1cd00 rw 
           cryptdevice=UUID=ca570b37-9e9c-4769-9fc1-d34cece0d55e:cryptroot quiet udev.log_priority=3 pcie_aspm=force 
           i915.i915_enable_rc6=1 i915.915_enable_fbc=1 i915.lvds_downclock=1 
           Desktop: awesome 4.3 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 42914BG v: ThinkPad X220 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: LENOVO model: 42914BG serial: <filter> UEFI: LENOVO v: 8DET76WW (1.46 ) date: 06/21/2018 
Battery:   ID-1: BAT0 charge: 38.8 Wh condition: 40.3/86.6 Wh (47%) volts: 12.4/11.1 model: SANYO 42T4940 type: Li-ion 
           serial: <filter> status: Unknown 
Memory:    RAM: total: 5.69 GiB used: 1.00 GiB (17.6%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Dual Core model: Intel Core i7-2640M bits: 64 type: MT MCP arch: Sandy Bridge family: 6 model-id: 2A (42) 
           stepping: 7 microcode: 2F L2 cache: 4096 KiB bogomips: 22337 
           Speed: 840 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 910 2: 858 3: 911 4: 903 
           Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 
           dtherm dts epb ept est flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx monitor msr 
           mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp sep smx 
           ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic 
           xsave xsaveopt xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Lenovo driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0126 
           Device-2: Chicony Lenovo Integrated Camera (0.3MP) type: USB driver: uvcvideo bus ID: 1-1.6:5 chip ID: 04f2:b217 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 124 size: 280x160mm (11.0x6.3") diag: 322mm (12.7") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.1.7 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520 driver: e1000e v: 3.2.6-k port: 5080 
           bus ID: 00:19.0 chip ID: 8086:1502 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0 
           chip ID: 8086:0085 
           IF: wlp3s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 558.92 GiB used: 30.06 GiB (5.4%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda vendor: A-Data model: SU630 size: 447.13 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 7A0 scheme: GPT 
           ID-2: /dev/sdb vendor: Kingston model: SMS200S3120G size: 111.79 GiB block size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s serial: <filter> rev: BBF0 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 35.39 GiB size: 34.58 GiB (97.72%) used: 15.45 GiB (44.7%) fs: ext4 dev: /dev/dm-0 label: N/A 
           uuid: 7e8e3239-02fa-4590-bdbc-248074d1cd00 
           ID-2: /boot/efi raw size: 525.0 MiB size: 524.0 MiB (99.80%) used: 25.5 MiB (4.9%) fs: vfat dev: /dev/sdb4 
           label: N/A uuid: 1D4D-5ACD 
           ID-3: /home raw size: 300.00 GiB size: 294.29 GiB (98.10%) used: 14.58 GiB (5.0%) fs: ext4 dev: /dev/dm-1 
           label: N/A uuid: fcff5cc3-af05-42b3-9459-ec39da3d82c3 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 14.90 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb1 label: N/A 
           uuid: 643c64d2-ea64-465a-b823-746b6a2503cd 
Unmounted: ID-1: /dev/sda1 size: 300.00 GiB fs: crypto_luks label: N/A uuid: 871d0ca8-31c6-4bf4-bfe4-c2fc1956c668 
           ID-2: /dev/sda2 size: 147.13 GiB fs: ext4 label: N/A uuid: e6962b62-bd2a-42b1-b3fa-fada3ff3048c 
           ID-3: /dev/sdb2 size: 35.39 GiB fs: crypto_luks label: N/A uuid: ca570b37-9e9c-4769-9fc1-d34cece0d55e 
           ID-4: /dev/sdb3 size: 32.60 GiB fs: ntfs label: N/A uuid: 0268BC2C68BC2079 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024 
           Device-1: 1-1.3:3 info: Upek Biometric Touchchip/Touchstrip Fingerprint Sensor type: <vendor specific> driver: N/A 
           interfaces: 1 rev: 1.0 speed: 12 Mb/s chip ID: 147e:2016 
           Device-2: 1-1.6:5 info: Chicony Lenovo Integrated Camera (0.3MP) type: Video driver: uvcvideo interfaces: 2 
           rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b217 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 1992 
Info:      Processes: 184 Uptime: 1h 57m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1506 lib: 330 
           flatpak: 0 Shell: Bash v: 5.0.18 running in: lxterminal inxi: 3.1.05

as far as my experience with multiple DE and WMs on the same machine, i found that rc.lua is the only file that controls awesomewm.
for double check, see if rofi keybind is not provided in two different instances [one with just key and the other as you mentioned. delete the unwanted and restart awesome

1 Like

Thanks for your reply rvc. I double checked the rc.lua file again to make sure I did not missed a second rofi keybind instance, and there was not. But following your cue that the awesomewm config is on top of the other DE/WM, I checked the other files in ~/.config/awesome and found the root cause:
The autorun.sh file (to start other stuff like dropbox, redshift, etc with awesome) had a xcape -e effectively modifiying the Super key to behave like Super+Ctl+Esc:
run xcape -e 'Super_L=Super_L|Control_L|Escape'
I commented out and restarted awesomewm, and as expected: Super does not call rofi anymore. Problem solved!!
Many thanks :blush: :+1:, if not for your comment I would have kept looking under the awesomewm config files, as I completely missed the line on my first attempts and was already self-persuaded it was something else.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.