Solved: Font size okay and not okay

My eyesight isn’t what it used to be. I have a big ultrawide monitor, and while I don’t need the text huge, I don’t want it itsy-bitsy tiny either.

I’ve gone into settings and my font size is okay, except in some applications where it’s not okay. For example, here in Firefox, the bookmark toolbar looks fine, just the way I want it.

But inside a myriad of other programs such as Audacious, Onlyoffice and Kdenlive, the font is almost too small for me to see. I’m looking at Audacious as we speak. Where we see “File Playback Playlist Service Output View” at the top, the type face is microscopic.

I can’t figure it out. I don’t recall having this issue using Xfce with other distros like Xubuntu. Can anyone help me out here?

Of course, I’ve gone into Settings > Appearance > Fonts and made my default font size 16 and the same with the default monospace font. That worked for the menus in my browser, but as I said, not in everything. I must be missing a global config file or something.

My computer has 68 gigs of RAM, 36 processors and here’s what I get when I run lspci from the command line:

[wayne@manjaro ~]$ lspci | grep VGA 67:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M] (rev c1)

Qt applications, as those you described, need to be configurate separate than the GTK+ applications on a DE that is something else than KDE Plasma. You probably either use Kvantum Manager or Qt5ct aka Qt5 Settings, so you have to set the font and font size from there …

1 Like

Thanks for taking the time to make a suggestion.

I’m in Xfce, not KDE Plasma. Hadn’t considered it being Qt applications. I’ll need to look into that.

Later: Thanks! Your suggestion lead me to the solution, outlined in a post below.

This issue was solved thanks to a suggestion from user bogdancovaciu from the Manjaro team. Thanks bogdancovaciu!

On the website “Stack Exchange” I found this solution. I did it and it worked for me. It’s originally from the archwiki.

Qt5 applications can often be run at higher dpi by setting the QT_DEVICE_PIXEL_RATIO environment variable. Note that the variable has to be set to a whole integer, so setting it to 1.5 will not work.

This can for instance be enabled by creating a file /etc/profile.d/


And set the executable bit on it.

I then rebooted and woolah! Problem fixed – sort of. Now it was too big!

My ultimate solution came by adding a line to the .profile in my home directory. In my case, I added the following line at the bottom of the hidden file .profile

export QT_SCALE_FACTOR=1.3
1 Like