[Solved] Cant change screen resolution using xrandr in new Gnome mikah

I dont know what is causing the issue.

Firstly I was using manjaro kde lysia from months then I switched to debian for some reason and then I wanted to switch to Gnome Mikah due to pacman and other great things.

But, the thing that stopping me is that I cant change screen resolution to “1280x720_60.00” or “1600x900_60.00” , I know how to change it as I have done it before on all the de’s. But this time it didn’t work, I thought this is a live session problem so I installed gnome mikah minimal to my system, but also after that same remains. Whenever I do xrandr -s 1280x720 at last my screen just goes no signal and after 15 or 20 seconds so it returns but I can do anything and sometimes the resolution remains the same I.e. 1024x768.

I tried full gnome mikah also as live session but the problem persists.

I can post any terminal or other info if anyone wants to help me…

Ok here’s the solution :slight_smile:
Just paste your (xrandr --newmode … && xrandr --addmode … && xrandr -s …) code in the file ~/.profile or open terminal and type

gedit ~/.profile

and paste all the screen resolution code in it, so everytime you login it will run that and will successfully change your resolution.

1 Like