[solved] Cannot redirect usb devices after moving vms to different path

Hello all.

I am using libvirt and qemu with virt-manager for my virtual machines.
I decided to mount my volume for my virtual machines at a different path.
( Before /home/name/virtual, now /mnt/virtual ).

After I made the appropriate adjustments in the respective xml for virtual machines and pools, all machines also start cleanly again, but, unfortunately, I can no longer forward USB devices.
The error message when forwarding is:

spice-client-error-quark: Could not redirect Logitech G413 Silver Me...
Error setting USB device node ACL: Error setting facl: Operation not permitted (0)

The permissions on the file system are the same as before, only the mount point of the file system has changed.
I have also already deregistered the VM and re-registered it using dumpxml etc.
The permissions on the drive are 0770 for tom.kvm
The user that starts libvirt is tom ( /etc/libvirt/qemu.conf )

Can anyone help me? I honestly don’t know what exactly to look for.

I was able to solve it myself.
For all those who have the same problem, my solution was:

According to this website,
FS#69428 : spice-gtk 0.39-1: USB redirection error,
there is a bug concerning this.
Why this only occurred after I mounted my virtual machines via a different path, I can not explain.
I just installed ‘spice-gtk’ again, which brought me a new version - 0.39-2 and immediately it worked again.

1 Like

and thank you!
Just yesterday I encountered the same issue, thus I bookmarked this post of yours to see any updates that you might have found.
I was looking around but I guess that bug report did not exist yet or was just being created while I was looking.

What I did - and what works:
I downgraded the package spice-gtk to the previous version (0.38-1).
It worked.

Reading the bug report - and as you said, I saw that a new version was available (0.39-2) as of yesterday night.
I updated (pacman -Syu) to install that - it works.

I’m on Arch - so the available package versions may not be the same as in Manjaro - I wouldn’t have thought that this new version would arrive to Manjaro stable so quickly.

Its ok, with Arch, I´m on Garuda.
Think the base is the same to all.

I used the archlabs installer - so: not proper Arch from scratch, but I’m lazy
Thanks again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.