[solved] After a reboot GRUB does not boot other OS

I have recently KDE Manjaro installed with GRUB as the bootloader. Grub install found 3 other Linux installs on my pc. After a (warm) reboot grub can not boot the other installs, errors: no such device followed by the UUID, file ‘boot/vmlinuz etc’ not found, you need to load the kernel first.
These unknown uuid’s are on the same nvme - drive. KDE Manjaro is on a sata ssd and boots fine at that point.
On a cold reboot all is good. I did not add or change drives since the Manjaro install.

This is on an ASUS motherboard with three drives and three UEFI boot partitions (which are all working as expected, i.e. during boot I can select the boot drive in the ASUS boot manager). Is this a known issue? any solution?

Very interesting. Can you compare blkid and fdisk - l result after cold boot to Manjaro, and after warm boot (when other systems on SSD are no longer available) , and check it results are 100% the same?
Also post result of inxi -Fazy And both commands mentioned earlier.

As always, provide details otherwise we only can speculate. You could start with

sudo fdisk -l

Cold boot and warm boot result in identical fdisk -l output and identical blkid output. I checked that with diff. The error is only there when booted via the Manjaro EFI / Grub.
fdisk -l

Disk /dev/nvme0n1: 232,89 GiB, 250059350016 bytes, 488397168 sectors
Disk model: KINGSTON SA2000M8250G                   

Disk /dev/sda: 232,89 GiB, 250059350016 bytes, 488397168 sectors
Disk model: Samsung SSD 840 
Disk /dev/sdb: 1,82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: ST2000DM005-2CW1
sudo blkid
[sudo] password for hans: 
/dev/nvme0n1p1: UUID= BLOCK_SIZE="512" TYPE="vfat" PARTUUID="
/dev/sdb1: UUID="BLOCK_SIZE="512" TYPE="vfat" 
  Type: Desktop Mobo: ASUSTeK model: PRIME B360M-C v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2811 date: 05/27/2020 

In the mean time I found posts (on kernel.org) relating to nvme errors related to the enabled Autonomous Power State Transition (power save), but I have not tested the fix mentioned there yet (https://bugzilla.kernel.org/show_bug.cgi?id=195039)

What solved this: grub2 - Why can't grub find the disk by UUID? - Unix & Linux Stack Exchange The Fast Boot option in the AMI / ASUS BIOS enables a minimal set of devices. If the nvme drive is not booted then nvme is not enabled at the time of boot. And then Grub on the other SSD can not find the UUIDs on the nvme drive.
So disabling Fast Boot has solved this.

Again an example of ‘you know what the right question is, after finding the answer’

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.