So this is a weird one

Hi All,
I’m running KDE.

So tonight I decided to change the thermal paste on my computer.
The computer is nine years old and the thermal paste is original from the manufacturer. I could hear the fan spinning up more frequently and thought some new thermal paste might help. There was barely any old thermal paste left on the cpu.

I unplugged my pc, waited a few minutes before proceeding and all went well… or so I thought. Note that I did have to unplug my SSD in order to be able to remove the heat sink but promptly plugged it back in.

The next time I booted up there was no Grub menu, it booted straight into windows.
I quickly went into the BIOS and changed all the settings back to what they were and booted into my Manjaro Live USB.

I searched the forum and followed these instructions and got Grub back, well sort of, now my computer booted straight into Manjaro, no Windows 10 option.

Luckily I had made a backup of my previous Grub config file and reverted to that, so now all is good except…

Now when my pc boots up, the boot up logo “HP” is much larger than it used to be and the Grub menu is also much larger. Note that when I am booted into either Manjaro or Windows the resolution is fine, I have a 1080p display.
It’s just during the boot up that the HP and then the Grub menu are huge. If I had to guess I would say that the boot up resolution is 480. Note this was happening even when my computer was booting straight into Windows.

I have no idea how to change the resolution on boot up.
Does anyone have any ideas?

My computer is an HP 600 G1 mini and I am using a Displayport to HDMI adapter (this was also unplugged when I was changing the thermal paste, I had unplugged everything)

I really liked my previous Grub menu, I had changed the background to the Manjaro wallpaper that I use and it looked great, but now, at the lower resolution, not so much.

Yea! I solved it!
In the BIOS I enabled Legacy boot, previously I had both UEFI and Legacy disabled.

I always had Quick Boot enabled, however, now that I enabled Legacy boot, a new menu option appeared in the Boot Order submenu (it was never there before, not even grayed out) for a Fast Boot.
I enabled Fast Boot and sure enough the resolution went back to normal and all is good once more.

Why enabling Fast Boot would change the resolution during the boot up is beyond me, but I’m glad it did.

If it’s a faux pas to solve your own problem please let me know and I’ll delete this post.
If it isn’t, then maybe it’ll help someone else one day.


It is better to self-solve a problem than to delete topic, or post “nevermind, I fixed it”

Sometimes it helps to write a problem down and get it outside your head

1 Like

And the solution may be useful for others!


Just wanted to add a funny anecdote, I literally RTFM for HP’s BIOS settings. :rofl:

There was no mention of the resolution changing during the boot up process.

1 Like

Sounds like you have a dead bios battery and unplugging everything made it so the bios reset to defaults, which also made the boot entry disappear (that you restored afterwards). Or maybe you shorted the clear CMOS pins and that reset the BIOS. You probably had to set things back where they were.

You can verify that by first saving current BIOS configuration to a USB (fat32) drive, and measuring the BIOS battery with a multimeter and see the voltage, but a 9 years old computer probably has a dead BIOS battery in it.

Fast Boot will most likely not enumerate all devices, but it should have no effect on the resolution. Simple to verify, disable/enable it and reboot and see the result. I would guess it is the Legacy Only boot option that changed things.

Very unlikely to me. It is either one or both, but “none”? I don’t think so.

My Skylake PC is 8 years old since this month exactly and i never changed my Bios battery yet.
But i also thinking that sooner or later i will have to replace it… but till this day all my settings saved and i had no issue.

When i read storys about his problems, im glad that i decided not to switch to uefi yet… MBR is superior and much secured but sooner or later i have to switch because newer nvidia cards (using 2080Ti actually) wont show a picture in Legacy Bios and AMD forced also people to UEFI :frowning:

There is no rule, the battery initially put in the computer may already by old or fresh, and there are different qualities, and the computer use also may affect the life span. But old batteries die, that’s just a given.

Also maybe you never unplugged everything for a period of time after 8 years to verify the battery holds the settings.

I don’t know where you get that from, but to each their own.

Im actually unplug my PC everytime i go sleep.

OK, still old batteries die, but that’s not a debate.

I read 2 years ago a intresting story, how AMD changed UEFI Voltage Settings on alot peoples system, only because of a Windows AMD GPU driver Update bug (from a mistake that AMD did at this time) and this users had a unstable system after that update.

This alone shows how dangerous UEFI is and how easy its possible that all PC’s could also gets destroyed from very high Voltage Settings though UEFI changes inside a OS!

For me it doesnt make sense to have full Bios access, while in a OS.
But this are the new epic features that today the PC industry is selling to us.

Think again, this is exactly how I had it set up and how I have another computer set up.

Is the battery dead? After nine years it wouldn’t surprise me, however I did unplug and power cycle the computer again while I was trying to resolve the resolution issue and it didn’t lose the BIOS settings that I had made so maybe something else is at play.

I do recall now, that when the computer was new, I had made several changes to the BIOS so I could multi-boot several Linux distros and then swapped hard drives and lost all of my BIOS settings. Putting my multi-boot hard drive back in did not restore those BIOS settings.

Maybe the BIOS is programed to detect a change in hardware and resets to default settings when it detects the hard drive has been unplugged (even if the same SDD is plugged back in)?

It’s a pain in the butt, but I’m sure they have their reasons for doing so.

It was more of a rhetorical statement.

It is either one, or both. Either BIOS/Legacy or UEFI, or both. What would be “NONE” boot option? That doesn’t exist, you maybe misread or misunderstand what the setting was for if “NONE” was an available option.

1 Like

I had both disabled in my BIOS.

OK if you want, you had neither Legacy nor UEFI boot option set, and you booted into “none” boot mode.

1 Like

I don’t know what to tell you.
I know what options my BIOS provides and what option I selected.
I’ll have to take a picture to prove it to you.

Whatever you want to spend time on, it is up to you, but you have to be either in Legacy mode, or UEFI mode, there is no other boot mode (OK there is CSM, when it is UEFI with support for Legacy aka both).

1 Like

As you can see both Legacy and UEFI are disabled.
I was multi-booting for nine years like this.

You disabled “Legacy Support” and “Secure Boot”. You did not disabled UEFI. Your system can not start without an UEFI Firmware.
It seems you misunderstood what “Secure Boot” is.


Just quoting myself for he sake of being right.