Snap installed but is not running, DirectConnect client EiskaltDC

i ran “sudo snap install eiskaltdcpp
on latest Manjaro (based on Arch, kernel 5.8.16-2-MANJARO) but when i then click the installed app menu entry to launch it, nothing happens (other snap app works good). I quickly looked into /var/log/ dmesg, journalctl and do not see anything related.

Do you have any suggestion? Also which DirectConnect (DC++) client do you suggest? I was unable to find any in official or AUR repo :-/ (eiskaltdcpp-gtk/qt is in AUR but building failed)

I am not a snap user - but first task is to check your snap services are running

systemctl status snapd.apparmor apparmor

Enable and start the services

systemctl enable --now snapd.apparmor apparmor

Thank you for your replies, though the Snap should be ready to run it, because I am launching other Snap powered app without problem. I tried yours mentioned commands and it not made it working.

I forgot i could try to run it from command line to discover some details. And indeed there are some errors, though i am unsure if it is supposed to be run like that:

$ eiskaltdcpp
    Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    Installing handler for: Segmentation fault
    Installing handler for: Aborted
    Installing handler for: Bus error
    Installing handler for: Terminated
    Signal handlers installed.
    Loading: Hash database
    Loading: Shared Files
    Loading: Download Queue
    Loading: Users
    UserList icons has been loaded
    Application icons has been loaded
    Fontconfig warning: FcPattern object weight does not accept value [40 210)
    Catching signal : Segmentation fault

Based on a topic from snapcraft, i checked dmesg for “eisk” (as eiskaltdc) and found:

sudo dmesg|grep -i eisk

[83261.422509] audit: type=1400 audit(1603789100.192:3591): apparmor=“DENIED” operation=“open” profile=“snap-update-ns.eiskaltdcpp” name="/proc/cmdline" pid=1289272 comm=“5” requested_mask=“r” denied_mask=“r” fsuid=1000 ouid=0
[83281.121470] audit: type=1400 audit(1603789119.889:3596): apparmor=“DENIED” operation=“capable” profile=“snap.eiskaltdcpp.eiskaltdcpp” pid=1289357 comm=“snapcraft-runne” capability=2 capname=“dac_read_search”

$ ls -l /run/user/

total 0
drwx------ 11 me me 280 26. říj 18.19 1000

$ ls -l /run/user/1000

total 4

drwx------ 2 me me 100 25. říj 20.17 pulse
drwx------ 3 me me 60 26. říj 18.19 snap.eiskaltdcpp
drwxr-xr-x 5 me me 140 25. říj 20.17 systemd

$ ls -l /run/user/1000/snap.eiskaltdcpp

total 0
drwxr-xr-x 2 me me 60 27. říj 09.58 dconf

$ snap logs eiskaltdcpp

error: snap “eiskaltdcpp” has no services

$ snap --version

snap 2.46-1
snapd 2.46-1
series 16
manjaro -
kernel 5.8.16-2-MANJARO