Smb client problem

I want to use the shared files of Windows Server 2016, which has an Active Directory. I am facing this message
Thank you for your guidance

I assume when a server is deployed with Active Directory it is a corporate environment.

You should talk to guy(s) responsible for the corporate network.

1 Like

We have Ubuntu and Linux Mint operating systems in the company, and I set them up myself and they work. They work without problems in the Microsoft network. But unfortunately, Manjero operating system does not work properly.
I have tried many ways, but I did not get any results, that’s why I wrote the problem here

These systems has - through Canonical a probable preconfiguration - so I suggest you check the smb.conf on the working systems to locate the diffs and possibly apply some of them to your manjaro system.

It is utterly and completely impossible to suggest any further troubleshooting based on a scrrenshot and the statement ‘it works with ubuntu and mint’

See these two pictures if there is a problem

pictures are useless - text - please

use a code fence

console output

resulting in

console output

check if you have the file smb.conf

ls -l /etc/samba

then provide the link returned from

cat /etc/samba/smb.conf | curl -F 'f:1=<-'

workgroup = WORKGROUP
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client min protocol = SMB2
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*
pam password change = yes
map to guest = Bad Password
usershare allow guests = yes
name resolve order = lmhosts bcast host wins
security = user
guest account = nobody
usershare path = /var/lib/samba/usershare
usershare max shares = 100
usershare owner only = yes
force create mode = 0070
force directory mode = 0070
load printers = no
printing = bsd
printcap name = /dev/null
disable spoolss = yes
show add printer wizard = no

comment = Home Directories
browseable = no
read only = yes
create mask = 0700
directory mask = 0700
valid users = %S

comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
guest ok = no
read only = yes
create mask = 0700

comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no

this is for a server - not a client

for a client you only need an empty smb.conf

I suggest you disable the smb and related services only using smbclient and an empty smb.conf

you shouldn’t need smb2 as server 2016 uses smb3 which id default for Arch and Manjaro

An interesting thing is that after restarting a few times, everything is fixed and I can easily access the shared files.