Sluggish performance, not sure if disk I/O or Networking?

I am somewhat new to Manjaro, although I have been using it on my laptop for a few months now. I decided recently to switch my desktop over to Manjaro Gnome from linux mint as I was having issues with my GPU in mint that I could not seem to resolve. So far almost everything has just worked out of the box using the proprietary drivers, which for me is great.

However, immediately from install I have noticed that everything runs a little sluggish. Programs take several seconds to open and open new windows/pages. and especially browsing the web is unbearably slow. I ran a speedtest and got the full 1gig up/down speeds, but browsing from page to page takes several seconds to load. Also in steam my download speed seems to be capped at 1MB/s despite changing download servers to try and mitigate the issue. I thought maybe I have some sort of disk I/O issue, but I am unsure how to diagnose this (and it is sort of a shot in the dark). I tried copying a couple big files to see if the disk performance was lower than expected, but the files seemed to copy at the speeds I would expect for my ssd (Several hundred MB/s).

I apologize if the issue sounds sort of vague, the best I can compare it to is as if I was running everything off a cheap sd card. Once something is fully loaded it seems to run fine, its the initial loading, or once something needs to be fetched from disk that seems to make everything slow down.

Output of inxi -Fazy

System:
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=eb63d11e-a946-451a-8dae-978f8a65fb47 rw quiet splash apparmor=1
  security=apparmor resume=UUID=a16db159-0f20-4c1d-863a-dad8046a2ecd
  udev.log_priority=3
  Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0
  Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: MEG X570 UNIFY (MS-7C35) v: 2.0
  serial: <superuser required> UEFI: American Megatrends LLC. v: A.B3
  date: 09/24/2021
CPU:
  Info: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 type: MT MCP MCM
  arch: Zen 2 family: 17 (23) model-id: 71 (113) stepping: 0
  microcode: 8701021 cache: L1: 1024 KiB L2: 8 MiB L3: 64 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 224080
  Speed: 2866 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz):
  1: 3175 2: 2056 3: 2054 4: 2056 5: 2199 6: 2291 7: 2202 8: 2199 9: 3610
  10: 2054 11: 3275 12: 2054 13: 3542 14: 2152 15: 2195 16: 2491 17: 2194
  18: 2052 19: 3528 20: 2072 21: 2056 22: 2199 23: 2199 24: 2055 25: 2194
  26: 2197 27: 2022 28: 2016 29: 2358 30: 2010 31: 2056 32: 3590
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: eVga.com. driver: nvidia
  v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 2d:00.0 chip-ID: 10de:1e89
  class-ID: 0300
  Device-2: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  bus-ID: 1-6:5 chip-ID: 046d:081b class-ID: 0102 serial: <filter>
  Display: x11 server: X.org 1.21.1.1 compositor: gnome-shell driver:
  loaded: nvidia resolution: <missing: xdpyinfo>
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
  direct render: Yes
Audio:
  Device-1: NVIDIA TU104 HD Audio vendor: eVga.com. driver: snd_hda_intel
  v: kernel bus-ID: 2d:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487
  class-ID: 0403
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  bus-ID: 1-6:5 chip-ID: 046d:081b class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169 v: kernel port: e000
  bus-ID: 25:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp37s0 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
  v: kernel port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 28:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3
  chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 4.66 TiB used: 36.45 GiB (0.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 2B2QGXA7 temp: 41.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
  model: WD4005FZBX-00K5WB0 size: 3.64 TiB block-size: physical: 4096 B
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
  rev: 1A01 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: PNY model: USB 3.1 FD
  size: 115.52 GiB block-size: physical: 512 B logical: 512 B type: N/A
  serial: <filter> rev: PMAP
Partition:
  ID-1: / raw-size: 862.18 GiB size: 847.58 GiB (98.31%)
  used: 18.35 GiB (2.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 69.03 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 539 Uptime: 0m wakeups: 0 Memory: 62.79 GiB used: 1.97 GiB (3.1%)
  Init: systemd v: 249 tool: systemctl Compilers: gcc: N/A Packages:
  pacman: 1247 lib: 403 flatpak: 0 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.09

I have already ran pacman -Syu to make sure everything is up to date. I just installed Manjaro yesterday, and the only additional software I have installed is Steam and Brave browser.

Any help would be appreciated.

Edit: Fixed the code tags (My bad)
Edit2: Updated inxi -Fazy output after BIOS update
Edit3: Updated inxi-Fazy output after kernel update to 5.15.2-2

Welcome to the forum! :wave:

It’s ``` (backticks), not ‘’’ (single quotes). :wink:

Please edit your post accordingly.

Your kernel is EOL. Could you try with 5.15? (Verify that you install the correct Nvidia drivers, otherwise you’ll end up without a login screen).

But I don’t think this is the solution. Could you provide the journal?

journalctl -b

Looks like there is a BIOS update in Sept. 2021.

By EOL I presume you mean end of life? If updating the kernel won’t break anything I can try doing that. The nvidia driver installed looks to be the latest proprietary one (which is what I want).

I would love to give you the output of that command, but the output is to large to put in this post, and I can’t put links in my post, how can I get it to you? Or is there specific stuff I can pipe into grep to trim it down?

I updated the BIOS and edited the OP to reflect the update. It hasn’t fixed the issue. Also, when I rebooted to get into BIOS Manjaro hung for a few minutes with three “busy dots” under the logo before the reboot completed. This seems like very odd behavior to me, my laptop never has issues like this.

I also updated the kernel to 5.15.2-2, the issue still persists unfortunately. I don’t know if it is of any assistance, but I also ran dmesg | grep error and got

[    2.408568] iwlwifi 0000:28:00.0: Direct firmware load for iwlwifi-cc-a0-66.ucode failed with error -2
[    2.408596] iwlwifi 0000:28:00.0: Direct firmware load for iwlwifi-cc-a0-65.ucode failed with error -2
[    2.408614] iwlwifi 0000:28:00.0: Direct firmware load for iwlwifi-cc-a0-64.ucode failed with error -2
[    3.790759] nvidia-gpu 0000:2d:00.3: i2c timeout error e0000000
[    3.790774] ucsi_ccg: probe of 0-0008 failed with error -110

Well I tried rolling back to 5.10.89-1 and giving it a month in the hopes updates would fix the issue, but still the PC acts very sluggish. Has anybody encountered an issue similar to this? I have manjaro on my laptop too, and there it works perfectly fine. I wanted manjaro on my desktop so I would have the same setup on both, but at this point I may have to switch back to linux mint, as the absolute lack of support and terrible performance is really a dealbreaker.

1 Like