Slower boot due to "Waiting 10 seconds for device /dev/disk/by-uuid/..."

when i boot the booting gets delayed by 10 seconds with the following message “Waiting 10 seconds for device /dev/disk/by-uuid/uuidofadisk”.
Before that my Linux waited 1:30 for this uuid because it was falsely configured in /etc/fstab as my swap partition (because i reinstalled linux and recovered from a backup via timeshift). So i replaced this entry in fstab with the correct uuide which i got from gparted. But how can i stop it from waiting this 10 seconds? The partition doesn’t exist so it doesn’t have to wait for it.
On the arch forum summone suggested running “mkinitcpio -p linux”, that doesn’t work because of a error, but “mkinitcpio -p linux59” runs succesfully, sadly the issue still persists.
Thanks in advance for your help.

Have you tried

sudo update-grub
sudo mkinitcpio -P

and rebooted?

Is your system fully updated?

If you wish more help you need to share some details of your system, e.g. by posting

inxi -Fazy
cat /etc/fstab
sudo lsblk
sudo fdisk -l
sudo parted -l
sudo efibootmgr -v

Have you any special boot configuration, like using systemd boot or are you using something else than grub?

Hello and thanks for your time.

Ohh yeah, sorry i forgot to mention it in the OP, i have a dual boot with windows and two harddrives. One SSD with the root and swap, and one hdd with home and windows.
My system is fully up to date with Pacman -Syyu
I am using grub.

sudo update-grub
sudo mkinitcpio -P

this didn’t change anything

inxi -Fazy

Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
root=UUID=ec300c01-b6a1-4f16-9aed-3dfd5879ee7f ro apparmor=1
security=apparmor resume=UUID=65b4ce2a-b34f-4e5e-9156-109a90e995a6
Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0
Distro: Manjaro Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x
serial: UEFI: American Megatrends v: 5602 date: 07/14/2020
Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
family: 17 (23) model-id: 1 stepping: 1 microcode: 8001138 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 84034
Speed: 2806 MHz min/max: 1550/3500 MHz boost: disabled Core speeds (MHz):
1: 2806 2: 1398 3: 2801 4: 1397 5: 1398 6: 1398 7: 2813 8: 1400 9: 2712
10: 1398 11: 1397 12: 1397
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia
v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 07:00.0
chip-ID: 10de:1b81 class-ID: 0300
Display: x11 server: 1.20.11 compositor: gnome-shell driver:
loaded: nvidia resolution: <missing: xdpyinfo>
OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01
direct render: Yes
Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 10de:10f0
class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Logitech G35 Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:4 chip-ID: 046d:0a15
class-ID: 0300
Device-4: Cambridge Silicon Radio CSR8645 type: USB driver: snd-usb-audio
bus-ID: 3-1:2 chip-ID: 0a12:1243 class-ID: 0102 serial:
Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.26 running: no
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 1.94 TiB used: 95.01 GiB (4.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: M4-CT128M4SSD2
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
rotation: SSD serial: rev: 040H scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA200
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 7200 rpm serial: rev: ABB0 scheme: GPT
ID-1: / raw-size: 101.66 GiB size: 99.57 GiB (97.94%)
used: 18.14 GiB (18.2%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 1001 MiB size: 999 MiB (99.80%)
used: 340 KiB (0.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 1.33 TiB size: 1.31 TiB (98.36%)
used: 76.87 GiB (5.7%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.6 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda2 maj-min: 8:2
System Temperatures: cpu: 47.1 C mobo: 0 C gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 316 Uptime: 2m wakeups: 0 Memory: 15.63 GiB
used: 1.73 GiB (11.1%) Init: systemd v: 247 tool: systemctl Compilers:
gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1550 lib: 486 flatpak: 0
Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.04

cat /etc/fstab

UUID=C659-89A0 /boot/efi vfat umask=0077 0 2
UUID=c7b745b8-11c8-4b0b-ab5d-246315a03734 swap swap defaults,noatime 0 0
UUID=ec300c01-b6a1-4f16-9aed-3dfd5879ee7f / ext4 defaults,noatime 0 1
UUID=25048f50-15c3-4461-b5ef-5f9c3b4cec24 /home ext4 defaults,noatime 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

as mentioned i edited the UUID for the swap myself because it was the false one after i restored a backup. The one it is waiting for is the old one.

sudo lsblk

sda 8:0 0 119.2G 0 disk
├─sda1 8:1 0 1001M 0 part /boot/efi
├─sda2 8:2 0 16.6G 0 part [SWAP]
└─sda3 8:3 0 101.7G 0 part /
sdb 8:16 0 1.8T 0 disk
├─sdb1 8:17 0 1.3T 0 part /home
├─sdb2 8:18 0 100M 0 part
├─sdb3 8:19 0 16M 0 part
├─sdb4 8:20 0 499.4G 0 part
└─sdb5 8:21 0 513M 0 part
sr0 11:0 1 1024M 0 rom

sudo fdisk -l

Disk /dev/sda: 119.24 GiB, 128035676160 bytes, 250069680 sectors
Disk model: M4-CT128M4SSD2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 22DD9DDB-D055-4972-A4D5-7EA0D79FBC61

Device Start End Sectors Size Type
/dev/sda1 34 2050047 2050014 1001M Microsoft basic data
/dev/sda2 2050048 36866047 34816000 16.6G Linux swap
/dev/sda3 36866048 250069646 213203599 101.7G Linux filesystem

Disk /dev/sdb: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: TOSHIBA DT01ACA2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 38A6A6BB-2BEB-43C8-9115-EEEB5F1E7DF3

Device Start End Sectors Size Type
/dev/sdb1 34 2858452991 2858452958 1.3T Linux filesystem
/dev/sdb2 2858452992 2858657791 204800 100M EFI System
/dev/sdb3 2858657792 2858690559 32768 16M Microsoft reserved
/dev/sdb4 2858690560 3905975094 1047284535 499.4G Microsoft basic data
/dev/sdb5 3905976320 3907026943 1050624 513M Windows recovery environment

Partition 1 does not start on physical sector boundary.

Partition 1 does not start on physical sector boundary.

is that something i have to worry about?

sudo parted -l

Model: ATA M4-CT128M4SSD2 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 1050MB 1050MB fat32 msftdata
2 1050MB 18.9GB 17.8GB linux-swap(v1) swap
3 18.9GB 128GB 109GB ext4

Model: ATA TOSHIBA DT01ACA2 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 1464GB 1464GB ext4
2 1464GB 1464GB 105MB fat32 EFI system partition boot, esp
3 1464GB 1464GB 16.8MB Microsoft reserved partition msftres
4 1464GB 2000GB 536GB ntfs Basic data partition msftdata
5 2000GB 2000GB 538MB ntfs hidden, diag

sudo efibootmgr -v

BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0002,0007,0001,0004,0003,0005,0006
Boot0000* Manjaro HD(1,GPT,b57ccd05-3830-3c45-8e1a-3b0f088f0741,0x22,0x1f47de)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0001* Hard Drive BBS(HD,0x0)…GO…NO…u.T.O.S.H.I.B.A. .D.T.0.1.A.C.A.2.0.0…A…>…Gd-.;.A…MQ…L. . . . . . . . . . .1. .3.7.X.B.4.A.S.A…BO…NO…u.M.4.-.C.T.1.2.8.M.4.S.S.D.2…A…>…Gd-.;.A…MQ…L.…BO
Boot0002* Windows Boot Manager HD(2,GPT,5991c559-13d7-49f4-84b0-4d7cc1921dc5,0xaa608800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…M…
Boot0003* UEFI:CD/DVD Drive BBS(129,0x0)
Boot0004* CD/DVD Drive BBS(CDROM,0x0)…GO…NO…u.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.4.N.S.9.5…A…>…Gd-.;.A…MQ…L.Y.K.C.9.H.B.0.L.3.8. .0. . . . . . . . …BO
Boot0005* UEFI:Removable Device BBS(130,0x0)
Boot0006* UEFI:Network Device BBS(131,0x0)
Boot0007* UEFI OS HD(1,GPT,b57ccd05-3830-3c45-8e1a-3b0f088f0741,0x22,0x1f47de)/File(\EFI\BOOT\BOOTX64.EFI)…BO

I hope the formating is done the right way.

I forgot, please post:

sudo blkid

This provides the actual UUID’s.

You still use kernel 5.9, this kernel won’t be updated any more, it is frozen and should not be used any more. Switch to 5.10 or 5.11 and if this works smoothly remove 5.9.

It could be that your /etc/default/grub still contains the old resume UUID, please check and correct if needed. Afterwards

sudo update-grub

and reboot.

sudo blkid

/dev/sda1: UUID=“C659-89A0” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“b57ccd05-3830-3c45-8e1a-3b0f088f0741”
/dev/sda2: UUID=“c7b745b8-11c8-4b0b-ab5d-246315a03734” TYPE=“swap” PARTUUID=“7c4d81f2-85f8-bd4c-a4fe-cb2581c7f830”
/dev/sda3: UUID=“ec300c01-b6a1-4f16-9aed-3dfd5879ee7f” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“4bea5840-f4c8-e742-84a6-cc04f9c07db0”
/dev/sdb1: UUID=“25048f50-15c3-4461-b5ef-5f9c3b4cec24” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“ccb796f9-e418-0a4b-8787-a1325af2a610”
/dev/sdb2: UUID=“7899-B92E” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“5991c559-13d7-49f4-84b0-4d7cc1921dc5”
/dev/sdb4: BLOCK_SIZE=“512” UUID=“2C369EC5369E9006” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“1c4af81e-3428-4590-8ac7-be4c5f192022”
/dev/sdb5: BLOCK_SIZE=“512” UUID=“80AC799EAC798F80” TYPE=“ntfs” PARTUUID=“f5f2c98c-5893-40e2-a7c0-2278487dde1e”
/dev/sdb3: PARTLABEL=“Microsoft reserved partition” PARTUUID=“70ce175f-968a-4196-8c07-75e6b163c010”

Ohh wow i totally missed that i run an old kernel, thank you. I will switch right away. Aren’t you recommending 5.12?

It could be that your /etc/default/grub still contains the old resume UUID, please check and correct if needed. Afterwards

It does, do i just remove this part or do i replace it with the uuid of the correct swap partition?

Replace in your /etc/default/grub




Save the file,

sudo upate-grub

and reboot.

At the moment I would recommend kernel 5.10 or 5.11, 5.12 is pretty fresh and could be a little buggy.


Thank you so so much, it works now and my system boot time has halved.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.