Slow Wi-Fi After Updating Drivers

After updating my drivers for my Wi-Fi, well…my Wi-Fi is not moving near as fast as it should. My other machine is connected via ethernet to my modem/router and it’s lightning fast (it’s running Linux Mint and I have a 300 MB connection from Spectrum). I actually got much faster performance from my USB dongle I plugged in to get everything updated earlier today, in fact. Here is my layout from the terminal to give you all an idea of what I have going on here:

Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 01:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp1s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: down mac:

My wireless card I’m using is a TPLink that worked just fine when I was running Windows 10 on this machine; is it a compatibility issue, do y’all think? I’m tempted to disconnect that one and just use the dongle from now on, unless there’s something I can do to rectify the current situation. Oh, and my desktop is XFCE, if that makes any difference, further. Thanks in advance!

Have look here:

I went to that page and it’s a bit confusing what it’s suggesting. If I reset the channel on my router, will that affect my main machine that is plugged directly into the modem/router or not? I tried getting into my router, but the wi-fi is so slow that the connection times out before even making the connection at all. Also, I’m not connected to the 5G option of my modem/router because for some odd reason the signal for that isn’t as strong as the conventional router. Weird!

OK, I took a closer look and did as the link suggested, and that appears to have done the trick. Thank you kindly!