Slow upload speed when connected to 4G/5G Router

I have extremely slow upload speeds (always exactly 0.21Mbits/s) using Manjaro with a 4G/5G mobile router but in Windows with other hardware has 20+Mbits/s (Ubuntu has the same problem for the computer with Windows).

I have tried connecting through ethernet, USB and Wifi to two different 4G/5G mobile router (Huawei B535 and ZTE MU5001) and two carriers with the same results. But if I connect to my cellphone hotspot (with the same SIM card(s) as the mobile router and in the same place) it works as fast as in Windows.

I have tried changing the DNS to without any change.
This started just a week ago and I don’t know what could be causing this.

The output from inxi -Fx is:

  Host: mario-hevia Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64
    compiler: gcc v: 11.2.0 Desktop: GNOME v: 41.4 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: LENOVO product: 20YRS0VP00 v: ThinkPad P15 Gen 2i
    serial: <superuser required>
  Mobo: LENOVO model: 20YRS0VP00 v: SDK0R32862 WIN
    serial: <superuser required> UEFI: LENOVO v: N37ET37W (1.18 )
    date: 12/24/2021
  ID-1: BAT0 charge: 95.4 Wh (100.0%) condition: 95.4/94.0 Wh (101.5%)
    volts: 13.1 min: 11.5 model: Celxpert 5B10W13959 status: full
  Info: 8-core model: 11th Gen Intel Core i7-11850H bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
  Speed (MHz): avg: 922 high: 1085 min/max: 800/4800 cores: 1: 906 2: 1023
    3: 1014 4: 893 5: 1085 6: 783 7: 948 8: 898 9: 794 10: 764 11: 800 12: 1055
    13: 1075 14: 946 15: 950 16: 831 bogomips: 79888
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Lenovo driver: i915
    v: kernel bus-ID: 00:02.0
  Device-2: NVIDIA TU117GLM [T1200 Laptop GPU] vendor: Lenovo
    driver: nvidia v: 510.54 bus-ID: 01:00.0
  Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 3-4:3
  Display: x11 server: X(dot)org v: with: Xwayland v: 22.1.0 driver:
    X: loaded: modesetting,nvidia gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    bus-ID: 09:00.0
  IF: wlp9s0 state: up mac: 70:1a:b8:76:70:d7
  Device-2: Intel Ethernet I225-LM vendor: Lenovo driver: igc v: kernel
    port: N/A bus-ID: 0b:00.0
  IF: enp11s0 state: up speed: 1000 Mbps duplex: full
    mac: 88:a4:c2:19:c0:bc
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 98.88 GiB (20.7%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKBA512TFH size: 476.94 GiB
    temp: 28.9 C
  ID-1: / size: 468.09 GiB used: 98.88 GiB (21.1%) fs: ext4 dev: /dev/dm-0
    mapped: luks-94603e79-e63b-4c81-ab73-3eab7db0d23e
  ID-2: /boot/efi size: 299.4 MiB used: 440 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 392 Uptime: 5h 15m Memory: 15.34 GiB used: 3.45 GiB (22.5%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1338
  Shell: Zsh v: 5.8.1 inxi: 3.3.15

@mario_hevia It could be a problem with the wifi protocols.

I guess your mobile phone just supports 11b/g. That works well.

Try this:

1 Like

Thank you, I tried it as you suggested but it didn’t change the speeds. Is there a way to be sure that the changes are taking effect, other than seeing that the file exists after I rebooted?

By the way, just to be clear the internet works like a charm with my phone, the problem is the “mobile routers” and I am pretty sure that at least one uses wifi6 so if I understand correctly it must support 11n, 11ac and 11ax.

Any other suggestions?

How about if you turn off bluetooth ?