Slow internet speed on one network

Hi, I have been having problems with internet speeds in the last few days on Manjaro KDE. The problem is present only on my home network, other networks work just fine(I have tried restarting the router, I did not change it’s configuration and the speed is normal on other devices so the problem is somewhere in my computer). When I run ping, I get one ping per second with normal latency so the problem could be with something like doamin resolution I guess…

System info

  Host: robomaze-rog Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.2.0 Console: pty pts/2 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401IH_GA401IH
    v: 1.0 serial: L7NRKD03789829A
  Mobo: ASUSTeK model: GA401IH v: 1.0 serial: P806MC03LV
    UEFI: American Megatrends v: GA401IH.209 date: 09/18/2020
  ID-1: BAT0 charge: 26.9 Wh (42.9%) condition: 62.7/76.0 Wh (82.5%)
    volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery status: Discharging
  Info: 8-core model: AMD Ryzen 7 4800HS with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1400 min/max: 1400/2900 boost: disabled cores: 1: 1400
    2: 1400 3: 1400 4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400
    11: 1400 12: 1400 13: 1400 14: 1400 15: 1400 16: 1400 bogomips: 92661
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M vendor: ASUSTeK driver: nvidia v: 510.54
    bus-ID: 01:00.0
  Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
    bus-ID: 04:00.0
  Display: server: X.Org v: driver: X: loaded: modesetting,nvidia
    gpu: amdgpu resolution: 1920x1080~120Hz
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.28-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: a8:7e:ea:ea:a4:fc
  Local Storage: total: 476.94 GiB used: 189.96 GiB (39.8%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
    temp: 30.9 C
  ID-1: / size: 367.34 GiB used: 189.93 GiB (51.7%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-2: /boot/efi size: 256 MiB used: 29.9 MiB (11.7%) fs: vfat
    dev: /dev/nvme0n1p1
  Processes: 440 Uptime: 17m Memory: 15.12 GiB used: 3.6 GiB (23.8%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1766
  Shell: Zsh v: 5.8.1 inxi: 3.3.13

What happens if you ping an IP address directly, such as Google:

Did you set the network card to auto-negotiate?

Pinging an IP address works with normal speed. This should mean that DNS lookup is somehow screwed up, right?

Did you set the network card to auto-negotiate?

Not that I am aware of…

What DNS provider are you using?

Where do you configure it? (Locally on your laptop? On your router?)

Some reliable and fast ones include:

  • Cloudflare

  • Quad9

  • Google (yes, they’re fast, whether you trust them or not)

I found out that I have configured DNS servers for this network, when I removed them, the problem went away… It’s kind of strange, because the set servers were google’s but it worked so… Thanks for your help!