Slow download only in web browsers

Hello!, i have a problem with manjaro that just recently came up. My internet is pretty fast (atleast its fast for me) and has no trouble downloading files however for some reason whenever i try to download anything from a browser it just drops to kilobytes a second and i have no idea why its perfectly fine at downloading anything from the terminal or pamac but for some reason i can’t download files fast on a browser i’ve tried multiple browsers and nothing has changed

you have some addons, vpn or proxy on your browsers, or some tor binary installed?

There’s no way to troubleshoot this aside from some gritty trial-and-error and process of elimination.

You already ruled out a specific browser or addon, since this supposedly occurs on any web browser. You’ve also ruled out a system-wide VPN, since this supposedly isn’t an issue with any terminal commands.

Or is there additional information you haven’t mentioned yet?

you mean:
clicking a link in (any) browser - to download what it’s linking to
is much slower than
… for instance:
in terminal using wget, like:
wget (copy/paste that same link here)

yes its only when downloading something directly from the browser when its slow wget is perfectly fine

no i don’t its just barebones and only with ublock, its been fine before with multiple addons

That is strange - I suppose you have already tried to use a clean, new browser profile?
Because it’s not network related when the same resource can be downloaded with command line tools without the issue.

yeah i’ve reset my browser profile multiple times and its still the same issue

I could not quickly find how to reset a profile from within the browser - but what I do when wanting a clean profile is:
I close the browser, then rename the old profile directory so I still have it just in case (stored passwords, for example …)

mv ~/.mozilla ~/.mozilla-backup

mv ~/.config/chromium ~/.config/chromium-backup

When the browser is restarted, a completely fresh profile will be created.
… not just the existing one reset

i’ve refreshed it just like you said but it still is very slow at downloading,
now another thing has happened, ping command won’t work anymore it just always packet loss

just to again confirm:

this in the browser is slow?

this command, downloading the very same thing, is fast?

The following are the same - one directly, one requiring DNS resolution:



which one works?

check your routers configuration - if you can
and power cycle it - if you can

next would be to configure a custom DNS

it’s very easy in NetworManager

yes the wget command is much faster than directly from the browser
and neither of the ping commands work its all packet loss

So, right now(!) you can actually download stuff in browser and using wget
one method is slow, the other faster,
but at the same time you cannot ping an IP or have it resolved from the name?

That makes absolutely no sense to me - I cannot help you.


its ok it makes no sense to me either