Sleep/Hibernate incompatible with 1TB Samsung 860 Evo SSD

First off, thank you for your time.

I believe there’s a conflict between my SSD, how my operating system is installed, and my ability to hibernate my machine successfully. Details below.

A few years back, I bought a Samsung 860 Evo SSD. For Linux, I was using a 1TB WD HDD and never had a single issue with sleeping it. At one point, I switched to a cheap SanDisk 100gb SSD and also had absolutely zero issues with sleeping the machine.

For whatever reason, when I switched over to the Samsung SSD, I no longer was ever able to get the machine to sleep correctly.

A few years ago, I first had the issue with Ubuntu, and I just couldn’t be fussed with it, so I started saving all my work and powering down every single time. I switched to Manjaro about two years ago and had some similar issues (it’s been so long, though, that I don’t remember exactly what happened other than it frustrated me enough to leave Manjaro entirely because it just never worked when I put it to sleep).

I eventually settled on Linux Mint about 1.5 years ago. Which I know is built off of Ubuntu, but for whatever reason, about 70% of the time, I can put it to sleep and successfully wake it up. However, there’s many times where it just crashes, too. Upon waking it says, “Something went wrong with your screensaver.”

I would like to go back to Manjaro is why I am asking here. Story continues…

I’ve never had issues with any other distros with my other drives, but I’ve consistently had issues with this Samsung drive. I assume it’s doing something super fancy and it’s causing problems ahaha.

One other detail I caught one time that might be relevant… there was a time that I put my Linux Mint to sleep, and when I came back, the screen powered on to the log in screen, but I got distracted for a second, so I never entered my password. I wasn’t gone for more than two minutes and I came back to the screen suggesting the system had crashed. I do NOT have any automatic hibernate stuff enabled due to me having so many issues with recovering it from sleep.

I am VERY unsavvy when it comes to all the backend and stuff here. I know very basic hardware stuff, though I do have a self-built desktop. I know just barely enough to get by. Speaking about terminal and stuff like that borders on gibberish. I can barely change a directory without someone spelling out the syntax really well for me. Thankfully, Linux has gotten really good in recent years.

That said, I would really appreciate it if you talked down to me a bit ahahaha. I don’t mind.

I’m asking here specifically in Manjaro land because I’m planning on reinstalling the operating system in the next day or two and my computer is used for my professional work, so I can’t afford for it to be down for long periods of time. Consider this a preemptive question.

I don’t understand the nature of the problem, but merely the symptoms of it. I’m hoping I’m describing a glaring issue that someone already knows precisely what’s wrong. Or at least we can narrow it down.

Other details that may or may not be relevant:

The machine has previously had Windows on the same drive (dual boot), but I had issues with Windows getting blue screened and got sick of it, so I installed windows on a VM later on a different drive and just clean installed the operating system.

I don’t remember if I use UEFI or whatever because I don’t remember or grasp what it means, but I remember having confusing issues with trying to install the operating system previously because I was using the wrong one. We concluded that I used the “newer” of the technologies, whatever it was and I had no issues (other than the sleeping issue) after that.

I don’t have the spec sheet at the moment, but I have an Asrock Extreme 6+ something or another full ATX mobo that is compatible with my Intel i7 4790k processor.

I have an Nvidia GTX 1080 TI. I don’t think it’s related to it or any of the other hardware specifically since I’ve previously run all the same hardware EXCEPT the SSD successfully.

I have, I believe updated my firmware on my mobo one time like 5 years ago or something. The mobo is pushing a decade old, but zero issues with it, and I’m not sure the firmware has even been updated since I originally did it back then. Again, it wasn’t an issue with the previous drives. It’s not to say it couldn’t have some issue with the Samsung one. Idk. Again, gibberish.

I’ve never attempted to update the firmware for the SSD itself. I don’t believe I have at least.

I do have other drives in the computer that I can free up a partition on if needed. I always kinda wondered if like…I somehow installed my swap or something to that effect on a different drive (like an HDD), if it would allow it to hibernate correctly.

Anyways, that’s all I know up front. I’ll be happy to answer any questions I can. I know I PROBABLY can’t definitively get an answer until I pull the trigger and just reinstall the operating system, but I’m hoping that since it’s something that’s happened (to some varying degree) on every single Linux distro I’ve used that it will be something glaring. I’ll likely try to reinstall the distro this weekend unless I get some very troubling news from someone on here. Also, if it’s related to something outside the operating system, then theoretically, I could probably fix it while my Mint is still installed and see if it worked, though it’s inconsistent when it crashes, so I don’t know definitively how I would test it.

Thanks again for your time and wisdom!

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

I appreciate the reply, @andreas85 !

I’m not sure that you read the post or not. I know it’s a tad lengthy, but I currently do NOT have Manjaro installed at the moment, but am seeking to reinstall it, so I cannot perform the command you’ve listed, I don’t believe.

I’m currently on Linux Mint. If there is a way for me to run a similar command that you know of, I’d be happy to do so.


I did read it. And i asked myself:

Why don’t’ you test manjaro with a live USB ?

Nobody can help you before you start doing something.

How to boot from USB into live Manjaro (for test):


So please try out manjaro. If you then need really help, everybody in this forum is eager to help you. (but then will need inxi-results to do so)

Linux is a lot learning by doing and some learning by reading (wikis and forum :mag: )
Good places are the arch-wiki and the manjaro-wiki

indeed :sunglasses:

For what it’s worth:

  • that belief could be tested rather easily (by trying …)
  • my Linux Mint installation actually does have the inxi tool installed by default
  • if that is not the case in your installation, it can easily be installed (apt install inxi)

no similar command is needed to gather and display all the information that this tool will provide :slightly_smiling_face:


1 Like

Agree with others that answered you. I have three samsung SSD’s, two older and one newer than yours. They all have various linux os’s on them (including Manjaro) and they suspend just fine. I think your problem is something else.


Thanks for the reply, @Nachlese

You’re right. It does seem to be installed. I tried the command that @andreas85 originally shared when he’d suggested it, but I got this error, so I assumed it didn’t work. I took your advice and did the install command, and was surprised it was already there. It just doesn’t work for some reason.

Hey, @andreas85

The reason I didn’t test it with a Live USB as you’re suggesting is because I’ve only had issues when it was installed on my SSD, and running it on a live USB wouldn’t have it on my SSD, so I would anticipate no issues considering I’ve never had a suspend issue on a HDD or my other SSD.

Regardless, I’m willing to try it. I stated I’m not Linux expert. I just couldn’t have imagined that the SSD would cause problems if the OS wasn’t installed on it.

Edit: and yes, since I couldn’t get the INXI command to work on Mint, I will try it on the Live Media.

Please have a look into Arch wiki: Power management

:mag: suspend
:mag: swap

Thanks for the reply, @laja !

It is entirely possible that it is something different, but I’m curious if the SSD itself is somehow associated with it. Like, if I installed the OS incorrectly using the SSD and because of it, it doesn’t work correctly. It’s totally possible I’m making some mistake like that, but I am installing the operating systems in the same way that I installed them on the HDD and my other SSD (both of which are unavailable to try reinstalling on again). The old SSD which I never had any issue with in my tower is currently running smooth in a legacy laptop running Mint, also. I’ve had no issues out of it. It all started once I put in the Evo. It’s not to say it “IS” the Evo itself, but it did all start then and it’s not ever stopped since then, regardless of LTS Ubuntu, Mint, or Manjaro.

I appreciate you sharing your experience with me. I’m fully open to it being “something else.” I just don’t know what. I know you guys are trying to help, and I’m of course sharing everything I know. I’m about to boot a live USB and try to get the inxi output from it.

it works here (on Linux Mint) without a problem

that was the command with long form options, intended to improve readability as to what the options might mean
(to someone unfamiliar and perhaps even suspicious of what command they are supposed to be issuing with sudo privileges)

the short form (and without sudo) that should suffice is:
inxi -Fazy

so: try that

the --admin option translates to adding -xxx to that command
(and, of course, needs to be actually run with “sudo” - to get admin permissions)

man inxi
will tell you more about it than you’d likely ever wanted to know :nerd_face:

Haha. Thanks again, bud. I’m still clearly not doing it right. Getting a Manjaro Live USB ready. I guess I’ll try it there.


Thanks for this.

So, when I hit the “suspend” button (I don’t have a hibernate button on my Mint), it should be storing it on the RAM, then it seems?

Btw, getting a Manjaro USB ready to do the inxi on. I’ve not had any luck with it on my Mint install thusfar.

Edit: I’m assuming I understood that wiki article on that part? It was really dense for me. I’m still kinda trying to get through it.

just omit the apparently problematic -y option
inxi -Faz

although, again, it does work here just fine …

1 Like

Thanks again! That seemed to work that time!

I did manage to put my inxi results in the disroot pastebin link.

I also managed to boot the live usb and sleep it three times in a row with no issues waking it.

I want to install the OS and just go for it obviously, but I do use this machine for my professional work on weekdays and I can’t afford to have it down. I’m just nervous if I install it and start having issues that I won’t be able to get them resolved before Monday. I will likely go ahead and install it anyways and just yolo it.

I’m trying to remember, but I feel the reason I couldn’t use sleep for Manjaro back then was it just never turned off. I hit the “sleep” button and the fans kept going and nothing ever turned off. I feel the screen went black, too, and froze, and then I had to fully reboot the computer.

Anyways, I appreciate your help regardless. I’ll likely try to install it in 12 hours or so. It’s almost bedtime where I’m at.

Of course it’s your decision but if that is the case, especially with an Nvidia Graphics Card,
I’d advise to resist the urge.

From the above interaction and from the output of your inxi we can see
that you are likely not very comfortable around the command line
(which you might need more than likely - and on a rather different system than the Ubuntu that Mint is based upon)
and you run a pretty old version of Mint (but still supported for two more years - mine is supported till 2027)

Linux Mint 20.3 Una base: Ubuntu 20.04 focal

My installation is:

Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy

(the most recent LTS edition)

It’s likely easier and safer to just upgrade that and live in peace for another few years … :sunglasses:

1 Like

Some Tipps:

  • use btrfs (with 2 devices and RAID10)
  • use snapper (or timeshift) so you can rollback in a short time (15 min ? )
  • make backups on an extern media
  • use XFCE (most stable) (and not KDE)
  • If you use btrfs you don’t need to be afraid of updates.
  • Not much tinkering (but with btrfs and snapper you can undo everything in minutes)
  • Install 2 kernels
  • Make your updates after reading the update-thread. But don’t procrastinate.
  • Have an live manjaro USB stick handy (just in case. This makes maintenance really easy)

I program with my PC (XFCE, btrfs, RAID10, snapper, dual-seat). I’ve had to rollback twice in what I believe was 5 years or more.

Andreas :footprints:
And have a lot of fun with manjaro :smiling_face_with_three_hearts:

1 Like