Skype runs at start up everytime; even when i have shutdown skype before reboot!

Please teach me reason and where to fix the problem.
KDE Plasma desktop computer (kernel 5.4 & kernel 5.10), runs skype everytime when start up; even when i have shutdown skype before reboot!
This happened all the time.
Why it stuck at “must run skype” at start up even i already shutdown the skype before shutdown ? Which folder and file in it dictate that behaviour ?


You can configure Skype to run automatically at startup within Skype settings.

Moreover, Plasma has an option to launch at startup all applications from last session.


This is probably your issue. KDE restores all previous windows if it can on login.

EDIT: I believe there is a way to change this.

Hello andrewysk,

  1. It can be some settings in Skype
  2. Skype can be in the following settings:
  1. You start your Desktop with the previous Windows / Prowgramms
  • System-Settings-> Startup and Shutdown-> Work Surface Session-> previews start with…
    You can try to start with empty Desktop. Starting with empty Deskop enviromental also speed up your boot time.

Hope you will find the right settings! :+1:

1 Like

Yes, i know plasma have that feature… but I HAVE close skype before i shutdown… In that cause plasma should NOT have run skype again when power up.

Unless as already said if Skype itself has an autostart setting.

You need to click “Save Session” (after fully exiting Skype) before you logout, reboot, or shutdown, otherwise it will keep using your previous session’s settings.

UPDATE: Skype cannot even be in the tray nor background when you do the above steps.

Can you please show me where is the “save session” button ? i only saw “start with an empty session” dial button (under system settings> startup and shutdown> desktop session.


It’s when you go to Leave on the menu.

It has to be done in the order explained above:

Also, don’t forget to rule this out:

Did you check to see if Skype is set to autostart in KDE’s settings (or its own settings)?

Yes, i removed auto start in skype already.

Just for the sake of knowing, can you please tell me

Just for the sake of knowing, can you please tell me
where "save session " button located ? I can’t find it.

Your menu is different than mine. (You might be using the latest KDE default menu launcher.)

You can try with a different menu (such as Legacy Application Launcher), or simply choose and apply the option to “Start with an empty session” under your Desktop Session settings window (shown in your screenshot.)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.