Size information appearing when I start/resize Konsole (with zsh)

Here’s what shows up in the middle of the window whenever I start/resize the terminal ever since I customized it with powerlevel10k, regardless of the window size when I open it:


The notification disappears after a couple of seconds. I think it shows the terminal size in characters.

What’s up with that?

Go over your customization - you have made a typo somewhere -

There is no way anyone is able to deduct where - you are the only one knowing whats going on.

You could use the Manjaro default customization provided with package manjaro-zsh-config.


Thank you for the reply. I tried to find a tutorial on the customization with manjaro-zsh-config. However, I didn’t find anything. The package page doesn’t seem to have a readme file.

I thought I couldn’t have made a typo because I opened the terminal and ran p10k configure.

Is there a command like that for manjaro-zsh-config?

manjaro-zsh-config also uses the dependence “powerlevel10k”.

But I can not reproduce it. What exactly have you configured?

Prompt style: Rainbow
Character Set: Unicode
Show current time? 24-hour format
Prompt Separators: Slanted
Prompt Heads: Slanted
Prompt Tails: Slanted
Prompt Height: One line
Prompt Spacing: Sparse
Icons: Many icons
Prompt Flow: Concise
Enable Transient Prompt? No
Instant Prompt Mode: Verbose

I had to do one thing manually - set the font, because not all symbols were coming out right.

i think something is wrong with your config only. share .zshrc

Does .zshrc contain information I should filter before sharing?

Not only .zshrc, but .p10k.zsh is for powerlevel10k theme.
.p10k.zsh was created by p10k configure

Here is the original document:

I was told zsh has nothing to do with the size notification and that Konsole does that.

I fiddled with the Konsole settings a bit. I’m not sure what did it, but the notification is gone.

EDIT Now it’s back…

EDIT 2 I like Konsole, but I switched to Kitty because I can’t remove the size notification. I customized zsh in Kitty and everything seems cool.
I had tried to do this with Alacritty, but the symbols weren’t rendering right.

Settings > Manage Profiles… > New > Appearance > Miscellaneous > uncheck Show hint for terminal size after resizing

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.