Since creating enabling swap I now get the following error on startup ERROR: resume: hibernation device 'UUID=68e5ef74-0684-4160-97e5-c0a dd778e416' not found

EDIT: To be clear I’m just asking for help regarding that error and not how to create and enable swap.

I tried to follow this guide initially but I was running into issues.

So I watched a couple youtube videos and kinda mixed and matched. I think the youtube videos were kinda dated on how you go about it, since I even copied the commands and made sure they match the video with no typos. Ultimately I went back to the above link and realised that I missed a step, which is why it initially wasn’t working. I managed to get it working just fine, but I’m thinking some of the stuff I tried doing before that is what may be causing the errors.

After sitting at that initial error on startup, then it shows a few more errors and then boots up. The following errors are:

[ TIME ] Timed out waiting for device /dev/disk/by-uuid/long serial
[DEPEND] Dependency failed for /dev/disk/by-uuid/same serial
[DEPEND] Dependency failed for Swap.
[ TIME ] Timed out waiting for device /dev/disk/by-uuid.
[DEPEND] Dependency failed for /dev/disk/by-uuid.

Once the computer finally boots up things seem to be running just fine, but obviously I’d like to fix this issue, because the bootup so much slower now, and even though I’m not noticing issues when I’m back on, I’m sure there’ll be some sort of problem in the background affecting the system. Also I haven’t actually done anything but using the internet since the issue, so it’s very probable that I will eventually run into issues.

I don’t know how great this command really is, but when I type sudo systemctl --failed in the terminal it says there are no errors found.

0 loaded units listed.

I’m still new to linux, so if you need more information that requires terminal commands, just let me know what they are. I know basic commands but need to look things up very often.

so this should fix everything? also dumb question for you. How exactly do I run a script from github? I thought maybe I could just download the zip, extract it, and then open the folder in vscode to run it, but there isn’t a file where I can click run inside vscode, so clearly I’m doing it wrong. You’d think I’d know this by now, but I guess I haven’t dived in since I need to properly learn how to use Git.

Just scroll the page down, there’s a readme with all the instructions.

hmm… didn’t end up fixing the problem. exact same issue on startup

Have you performed the step “remove swap from Grub”?

Not sure how to do that… One quick update tho, with a little help from someone on reddit, I was at least able to fix all the errors that were popping up after ERROR: resume: hibernation device ‘UUID=68e5ef74-0684-4160-97e5-c0a dd778e416’ not found. So it’s not nearly as slow as a boot, but still a bit slower than normal. So now I just see this error when shutting down and when booting up.

This was the advice from reddit:

" It’s saying the UUID is wrong. So maybe you changed your partition or set it up wrong in the first place. Try running lsblk -o NAME,UUID , see which is the correct UUID for your swap partition, and fix /etc/fstab to the correct value."

Finally solved it with a little more help. The only thing I had to do after the recommended step was to was to fix the UUID in grub and give it the same value as swap. Thanks for your taking your time to try and help though

1 Like