Since 5.8.x kernel required renesas xhci firmware blob

@philm please merge files firmware from AUR: AUR (en) - upd72020x-fw into manjaro-firmware package against lastest changes:
kernel/git/torvalds/linux.git - Linux kernel source tree

Without fw files when mkinitcpio working:

  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci

Related: Xhci_pci is missed in Linux Kernel 5.8

Thanks :heart_decoration:

FW SOURCES: GitHub - denisandroid/uPD72020x-Firmware: Firmware for the uPD720201 and uPD720202 (+Flashing utility) (2.0.1.3, 2.0.2.0, 2.0.2.6) (+ Win driver)

REFERENCES:
https://bbs.archlinux.org/viewtopic.php?pid=1923657#p1923657
https://bbs.archlinux.org/viewtopic.php?id=258184

2 Likes

Expect a fix with upcoming 5.8.12 kernel …

3 Likes

Seems this is a bigger issue for some USB-3.0 Hubs. With the recent changes in 5.8 development cycle the renesas_usb_fw.mem is now needed for some rensas controller like uPD720201 and uPD720202. However this firmware is due to its license not distributable.

There are some commits:



If we look closer we got this note:

config USB_XHCI_PCI_RENESAS
	tristate "Support for additional Renesas xHCI controller with firwmare"
	depends on USB_XHCI_PCI
	---help---
	  Say 'Y' to enable the support for the Renesas xHCI controller with
	  firwmare. Make sure you have the firwmare for the device and
	  installed on your system for this device to work.
	  If unsure, say 'N'.

So we will try to remove that driver support as recommended by upstream and revisit it, as soon as the firmware lands into linux-firmware.

See also:

2 Likes

See also:


If you search further you may find these info:

The firmware image can be extracted from the Windows driver.
A viable source is the "PP2U-E" (USB3.0 Host to PCIe Adapter)'s
"Firmware download (ver 2.0.1.3) Jun 15, 2012" file. It contains
the K2013080.mem file which needs to be placed in /lib/firmware.

https://lore.kernel.org/patchwork/patch/686290/

So it seems there are so many firmware blobs out there, however no firmware in linux-firmware yet. We have to see what happens if we disable the driver …

Looking deeper into the rabbit hole …

https://patchwork.ozlabs.org/project/lede/patch/e8c4009309d459914cffc23152a2fa672029e931.1468437389.git.chunkeey@gmail.com/

The question is now why Netgear is releasing K2013080.mem as GPL under the folder /WNDR4700-V1.0.0.56_GPL_SRC/target/linux/wndr4700/renesas/ and it is not yet released by Renesas themselves.

https://www.downloads.netgear.com/files/GPL/WNDR4700-V1.0.0.56_GPL_SRC.tar.bz2.zip

Another link to get the firmware is from here:

However, I’m still not sure if we can redistribute it as is. So I’m still avoiding this for Manjaro.

2 Likes

FYI

I have a Renesas USB 3.0 based card. I get the ‘possibly missing firmware’ message when I run mkinicpio. I do not have a Renesas firmware blob anywhere on my system.

The card works fine since kernel 5.8.4.

The firmware is on the card. The early 5.8 series had a bug in the new Renesas USB host module and thus failed to initialize the card.

So it seems after all it is the following commit which breaks the support of some USB 3.0 controllers:

It more or less forces the driver to look for the firmware as needed. So by deactivating the xhci-pci-rensas driver you still get the notification that you might miss some firmware. So it is hard to fix this.

You can see that also in 5.8.y changelog.

Therefore it would be great to know if 5.8.12-3 fixes the issue, which I just had committed to our unstable branch.

I just updated my mirrors and they report they are in sync, but I only have 5.8.12-2. :man_shrugging:

1 Like