Since 20.1 Mikah, Manjaro releases suffer a network-related freeze

I’m not sure where to go with this problem, as although I’ve used Manjaro on my machine for some years, I can no longer run Manjaro on my machine from 20.1 Mikah onwards, including 21.0 Ornara which I’ve just tried. The system installs and I can connect to a wireless LAN, but as soon as there is network traffic, the machine freezes. 20.0 Lysia doesn’t exhibit this problem, neither did any of the releases before it.

The installation detects and installs the Broadcom BCM4313 802.11bg driver and otherwise appears fine. I could understand if the device is no longer supported, but that doesn’t appear to be the case. What would be the approach to use here? Should I run with 20.0 Lysia and update it? I haven’t done that yet, for lack of time, but if that’s the right way, can someone advise, thanks.

Hello @chrisp,

Have you ruled out a hardware problem? Based on your description, it sounds possible that at some point the Wi-Fi adapter started behaving erratically.

Maybe try comparing the behavior while running live USB images with the latest Manjaro release, an older Manjaro release that you know worked and maybe also another distro.

Thanks for the reply @jeancf As I mentioned, I’ve tried 21.0 Ornara just downloaded from the current downloads page, running both as a live boot and as an installation. Reverting to earlier Manjaro releases up to 20.0 works fine. No, the hardware is fine, it still works perfectly with a Manjaro 20.0 Lysia and earlier, works with Windows.

To summarise:

20.0 Lysia - works as live boot and installation, no problems
20.1 Mikah - detects wireless and connects, hangs on network traffic
20.2 Nibia - detects wireless and connects, hangs on network traffic
21.0 Ornara - detects wireless and connects, hangs on network traffic

I could run 20.0 Lysia but an important purpose of my machine is for running VirtualBox and 20.0 has kernel 5.6 and this factor caused me some stuggles. The wiki page for installing VirtualBox in Manjaro indicates the following:

mhwd-kernel -li
sudo pacman -Syu virtualbox linux54-virtualbox-host-modules  *{replacing 54 with the kernel version}*

Manjaro 20.0 contains the 5.6 kernel, and the command fails when replacing 54 with 56. I don’t know the solution to that. So no, the problem has been introduced with Manjaro 20.1 Mikah and I’ve methodically shown this by trying every version up to latest.

Kernel 5.6 is not supported anymore and has been removed form the repository. You should switch to the latest LTS Kernel 5.10 or go back to the older but still supported LTS Kernel 5.4.

Because Kernel 5.6 is not supported and removed, you can not install the Virtualbox Host modules for this Kernel.

1 Like

There is no easy solution to this - as you are running a completely outdated system.

I think the most safe solution is to boot the system using a live media.

Below is assuming a default system using UEFI with $esp as first partition and root as second partition - also assuming opensource graphic drivers.

Open a terminal and su (if prompted for password it is manjaro)then mount your root and efi partition - chroot the system and update it

$ su -
# mount /dev/sdy2 /mnt
# mount /dev/sdy1 /mnt/boot/efi
# manjaro-chroot /mnt /bin/bash
# pacman-mirrors --continent
# pacman -Syyu linux510
# exit
$ reboot

There are many posts on the old forum about BCM4313 issues that may be relevant to the old ISO versions you are using

This is the 3 latest posts confirmed as solved

BCM4313 - Broadcom Wi-Fi - Which Driver to use? - Networking - Manjaro Linux Forum

BCM4313 - Which Bluetooth Firmware? - Networking - Manjaro Linux Forum

[SOLVED] Slow Wi-fi on Broadcom BCM4313 Adapter (rev 01) - Newbie Corner - Manjaro Linux Forum

That may help you get your wifi device working, or help you to find relevant data about your system for further troubleshooting

1 Like

Thanks @xabbu and @linux-aarhus Just to clarify though, this is a fresh system I’m installing, thus there is no “outdated system” to complicate things here. When the latest download of 21.0 Ornara froze the system, I decided out of curiosity to download 20.1 Mikah, and so on. I found that 20.0 Lysia worked fine, albeit the VirtualBox and kernel complication that stopped me.

In other words I’m starting with a fresh installation, but with the constraints that there has been some kind of bug introduced in the Broadcom drivers on Manjaro 20.1 Mikah.

Does the procedure you mention, @linux-aarhus still apply, given the above? Many thanks again.

Thanks @nikgnomic I’ve only just seen your reply, but taking a look now at the BCM4313 threads. There’s quite a bit I need to catch up with there, but I can see the objective, more or less, which is to disable/blacklist the Broadcom driver on boot and use another. I’ll experiment with this.

I’m a bit disadvantaged at the moment, stuck in a foreign country in lock-down, without access to the vast range of machines I normally have at my disposal!

I read the initial topic and the comments and it seemed you were running a system not yet updated - and on kernel 5.6.

This makes is an unsupported system because 5.6 had EOL long time ago - and paritially synced systems are unsupported.

If however you are installing a fresh system - I think 5.10 is the current kernel on ISO - then there is a hardware issue.

Broadcom is wellknown for issues on Linux - at least for wireless and wifi - and broadcom should be shunned if at all possible - but that is not always an option.

I avoid broadcom for their lack of linux support and their closed source blobs.

1 Like

You’re more or less correct @linux-aarhus yes, but it’s just that I only tried the 20.0 Lysia as a possible solution, since the Broadcom problem doesn’t show itself on that version. But then I was thwarted by the 5.6 kernel and my need to install VirtualBox, hence the question that maybe I can update it.

I accept what you say about Broadcom issues on Linux. It’s a machine that I use when travelling and has been a good solid workhorse, apart from this. I could buy another machine, but I’m against adding to the world’s mountain of obsolete IT equipment, which pains me somewhat!

That’s great - I would recommend either to use the older ISO - with a kernel know to work or wait with any updates until you are better equipped - so to speak - I am afraid Broadcom hardware will continue to be untamed child for years to come.

1 Like

Just to conclude with what I’ve done to resolve this little challenge today. I installed Manjaro 19.0.2 which is provided with the 5.4 LTS kernel. This then presented no problems following the VirtualBox installation…

sudo pacman -Syu virtualbox linux54-virtualbox-host-modules

During the process it downloaded approximately 1.8GB of updates, which of course concerned me that it was going to break the Broadcom driver, but thankfully it didn’t and everything is fine.

This isn’t a current release of course but it makes little difference to me for my needs. All I need is a stable host that allows me to run separate VMs for whatever support it is that I’m responding to. Thanks for the help with this today.

When you sync your system you make it current.

So now you have a current Manjaro on LTS kernel - I am very pleased you succeeded this way.

So one conclusion to make regarding the broadcom driver - it is kernel related with newer kernels - so staying on kernel 5.4 will most certainly make your system continue it’s valued stability.

Thank your reporting back :+1:

1 Like

Okay, thanks for mentioning that - I’ve learnt something from this. I’m rather guilty of not having familiarised myself with the concept behind the rolling release method, despite using Manjaro for several years. I tend to just install and leave, until it’s time for a fresh hard drive swap, which is essentially how this came about this weekend.

Would it be true to say that although I installed from 19.0.2 yesterday, I am not actually running 19.0.2 now, but 21, notwithstanding that the kernel is still 5.4?

Yes, it seems it was the kernel, agreed. Interestingly, now I can see that on booting with kernel 5.4, the system immediately finds the wireless connection and locks straight onto it. In the past with this same machine when I was running earlier releases of Manjaro, the wireless connection was always slow to complete, often requiring me to reboot again. Sometimes I was able to manually connect without rebooting, but rarely. This was something I lived with, but noted that it wasn’t quite right.

Answered my own question, I guess. It can’t really be any clearer than this. Like magic…
$ cat /etc/lsb-release

1 Like

Hi @chrisp,

Could you try to disable randomization in the Network manager?
First, create
sudo touch /etc/NetworkManager/conf.d/broadcom_wl.conf
Then, edit the file and include this three lines.


Hope this help, regards