Simultaneous output not working

I use the Simultaneous audio option from the pulse auto preferences tool to use two of my speakers at once. It worked fine until I installed Pulseaudio effects and the Simultaneous still showed in the Gnome sound settings but there was no sound being played from it. Each individual speaker works and I have removed Pulseaudio effects with the same problem after multiple reboots and reinstall of pulse audio preferences. Any ideas?

When Pulseeffects was installed it should have been set to be the (virtual) default-sink so audio processing applies to all audio.
Then the (virtual) Combined sink for Simultaneous Output can split processed audio to both speaker output (hardware) sinks

I suspect that after uninstall of Pulseffects, the default-sink has been changed to one of the hardware Sinks instead of the Combined virtual Sink

Use this to check PulseAudio setting for default-sink

pacmd dump

The data will also show if module-combine-sink for the simultaneous output is present and working

Output of pacmd dump. Thank you.

### Configuration dump generated at Sun Jan 17 14:48:05 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_38_00.1" card_name="alsa_card.pci-0000_38_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="2" name="usb-Microsoft_Microsoft_LifeCam_VX-5000-02" card_name="alsa_card.usb-Microsoft_Microsoft_LifeCam_VX-5000-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_38_00.6" card_name="alsa_card.pci-0000_38_00.6" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-combine-sink 
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:1 xauthority=/run/user/1000/gdm/Xauthority
load-module module-x11-xsmp display=:1 xauthority=/run/user/1000/gdm/Xauthority session_manager=local/desktop:@/tmp/.ICE-unix/3603,unix/desktop:/tmp/.ICE-unix/3603
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_38_00.6.analog-stereo 0x947c
set-sink-mute alsa_output.pci-0000_38_00.6.analog-stereo no
suspend-sink alsa_output.pci-0000_38_00.6.analog-stereo yes
set-sink-volume combined 0x6800
set-sink-mute combined no
suspend-sink combined yes
set-sink-volume alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1 0x570c
set-sink-mute alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1 no
suspend-sink alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1 no

set-source-volume alsa_input.usb-Microsoft_Microsoft_LifeCam_VX-5000-02.mono-fallback 0x7d7d
set-source-mute alsa_input.usb-Microsoft_Microsoft_LifeCam_VX-5000-02.mono-fallback no
suspend-source alsa_input.usb-Microsoft_Microsoft_LifeCam_VX-5000-02.mono-fallback yes
set-source-volume alsa_output.pci-0000_38_00.6.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_38_00.6.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_38_00.6.analog-stereo.monitor yes
set-source-volume combined.monitor 0x10000
set-source-mute combined.monitor no
suspend-source combined.monitor yes
set-source-volume alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1.monitor 0x10000
set-source-mute alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1.monitor no
suspend-source alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1.monitor no

set-card-profile alsa_card.pci-0000_38_00.1 output:hdmi-stereo-extra1
set-card-profile alsa_card.usb-Microsoft_Microsoft_LifeCam_VX-5000-02 input:mono-fallback
set-card-profile alsa_card.pci-0000_38_00.6 output:analog-stereo

set-default-sink alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1
set-default-source alsa_input.usb-Microsoft_Microsoft_LifeCam_VX-5000-02.mono-fallback

### EOF

The combined sink is present and looks OK

but the default-sink has been set to HDMI output:

set-default-sink alsa_output.pci-0000_38_00.1.hdmi-stereo-extra1

Use this command to change the default-sink:

pacmd set-default-sink combined

It does the same thing as when I change the sound output in the settings to simultaneous output, it outputs no sound on any of the speakers. Thanks for your help.

Audio streams should connect to default-sink first, but PulseAudio will respect a user preference to use another sink output before default-sink
A stream may have to be re-directed manually if it was previously set by user to use a specific sink output

module-combine-sink should automatically connect to all available sinks when loaded
(unless the option ‘slave=’ with a list of named sinks is used when loading the module )
Simultaneous Output should show the connected slave outputs in PulseAudio controls:

If the slave outputs are not shown correctly in PulseAudio controls, try unloading and re-loading module-combine-sink for the module to detect available sinks
If simultaneous output was set using GUI controls, turn the setting off and back on again
or use this command:

pacmd unload-module module-combine && pacmd load-module module-combine
1 Like

Yes, it worked! Thank you so much!!!

1 Like