Simultaneous audio output

Hi,

I want to use speakers and headphones at the same time. Speakers are connected to the back-side jack of my PC, while headphones are connected to the front jack. When I connect these two, startup Manjaro, what happens is, that the system keeps constantly switching between headphones and speakers, or outputs, not sure. (see media below)

This is the same thing that happened to me on Windows, but after many tries of installing Realtek Audio Drivers, etc., I think I managed to get rid of this problem by disabling the front panel jack detection, because it’s both microphone & audio input. I can not seem to have any option like this on Manjaro (Linux) here.
Then both headphones and speakers output was working correctly, simultaneously, which means that the same audio is going out from my speakers and headphones, at the same time.

What I have done up till now, is installed “paprefs” and checked the checkbox in the simultaneous tab (add virtual output device for simultaneous output on all local sound cards). Problem persists.

I am lost, tried Googling much, but haven’t found anything yet.

Thanks in advance. Any help appreciated.

(If you need any information regarding my system, please ask.)

Video: https://www.youtube.com/watch?v=1lqGTMr1sko

1 Like

It is my understanding that in most systems like yours, the front and rear audio ports use the same output, and when you plug into the rear, it switches audio to the rear, if you plug into the front, it switches to the front. I don’t believe you can have output to both, only one or the other. You can have speakers and one audio port but not both audio ports.

Audio output keeps constantly switching from front to back, back to front, yes.
But on Windows, I have fixed it. I literally could have the same audio from my speakers and from my headphones at the same time, both plugged in, no problem, with 1 motherboard sound card. I should be able to achieve this on Linux as well, shouldn’t I?

If you can do it on Windows then you should be able to do it on Linux, clearly it is not a hardware issue. Sounds like paprefs and jack would be the tools.

Of course, but I am lost, I tried stuff like hdajackretask, disabled or forced some jacks… but it failed, I am partially new to Linux.
Hence why i came here and asked for help regarding this.

Here is the video of what is happening.

I suggest you turn off simultaneous output in paprefs if it is not effective for what you want
Most Realtek devices do not have independent devices for Headphones and Speaker outputs to need this

I also suggest you run hdajackretask and click Remove boot override to clear any changes

Check audio playback devices to find the card number for the Realtek onboard audio device

aplay -l

(for most desktop systems the GPU is usually card 0 and Onboard analog audio card 1)

check ALSA hardware controls for the appropriate card

amixer --card=1

that will show all the ALSA audio controls, and should show a setting like this:

Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

use this command to disable Auto-Mute

amixer --card=1 sset 'Auto-Mute Mode' Disabled

That might resolve most of the problems with jack detection, but the flickering between Headphones/Speaker connections showing in the video suggests jack-detection is malfunctioning and one of the jack sockets may be damaged. If broken jack is still affecting audio outputs, it might need to be disabled in hdajackretask and another jack retasked for headphone or speaker output

2 Likes

Yes, one would think so. But on Windows it works flawlessly at the moment. I can enable both speakers and headphones, no flickering between them.

I will try out your guide, and give feedback later. Help much appreciated.

I did what you said, I think I actually had it already disabled.
Either way it did nothing.

What did you mean by retasking jack?

If jack-detection is disabled, PulseAudio GUI controls should no longer show Outputs for Headphones and Speaker outputs as (plugged-in) or (unplugged)

Checking Pulseaudio sink outputs pacmd list-sinks would show output ports as available: unknown if jack detection is disabled
but if jack detection is still active, output ports would be shown as available: no or available: yes

hdajackrestask allows user to retask/reconfigure HDA audio devices in many ways

jack-detection can be disabled for all jack sockets by enabling the Parser hints option
left-click on the Value for jack_detect to change if from default to no


More Notes on HD-Audio Driver - hint-strings — The Linux Kernel documentation

OR jack-detection can be disabled for individual jacks by enabling Advanced Options

For either option, click on Install boot override and reboot system to ensure the configuration changes are loaded

2 Likes

Tried to play with those settings, unfortunately nothing helped it. Either I can only hear from one device or the flickering…

Can someone pleas tell me how can I reinstall all audio drivers?

Video shows both audio playback and capture ports were switching at the same time, so there might be a problem with connection between motherboard and the front panel audio jacks?

Playback output is switching between ‘Headphones’ and ‘Line Out’
but capture input is switching between ‘Front Microphone’ and ‘Front Microphone (unplugged)’
so the hardware problem might just be the front panel microphone jack-detection malfunctioning
If the microphone jack is malfunctioning, disabling detection for output jacks only would not be effective, but parser hint to disable all detection should work

If only one audio device is audible, an output may have been muted, or Auto-Mute enabled when ALSA has been reconfigured with boot override
Check ALSA settings with amixer -c1 or alsamixer -c1