Simple nvidia driver config issue

im sure this is idiotic oversight in the extreme on my part, but here i am.

just installed manjaro, working great, love it. computer has an nvidia 1050ti gpu. currently im using the open source driver and want to switch to a proprietary one to improve gaming performance. opened system settings GUI and went to hardware configuration. selected “auto install proprietary driver” and my computer installed the video-hybrid-intel-nvidia-450xx-prime for me.

my issue… how to i configure my computer to start using this new driver instead of the opensource one it is currently using? i read like half a dozen threads on this site and went through another half dozen web pages which all told me how to install a new video driver, but not how to configure my system to use it instead of the open source one.

There some ways to use dual graphics, you have bumbleebe, opimus manager,optimus switch. Each one have their own way to work.
Bunbleebe is the oldest and your cards have to be compatible. I don recommend it
Optimus manager have 3 optios, use each one of the cards or both at the same time. For your combination of cards looks the easy way. Check this post
Optimus switch. Only 2 options, you can use only one card at the same time.Guide here

i’m not looking to download a utility to allow me to alternate between using my intell and nvidia GPUs, i want to know how to switch the drivers my computer is currently using. i believe it is using “video-linux” which was installed by default. i would like to use a proprietary driver instead.

manjaro has a sleek GUI that makes it easy to install new drivers, i just cant find the “button” i need to press to select which driver my system is using.

If you installed the video-hybrid-intel-nvidia-450xx-prime config, then the nouveau driver should’ve been blacklisted automatically. You can confirm it by running cat /etc/modprobe.d/mhwd-gpu.conf, the output of which should have blacklist nouveau in it. You can run any application on the nvidia gpu using prime-run COMMAND (e.g. prime-run glxgears). If you want to run the Xorg server on the nvidia gpu, then I suggest you use optimus-manager.

Usually - the system will use the driver upon reboot.

The culprit - probably - in your case is a laptop with dual graphics - and those are by definition a pain.

I only have one system - a ThinkPad - with Intel/Nvidia combo and am using the - happily - the opensource driver - I may add I am not a gamer - which is kind of a disadvantage when troubleshooting these issues.

On the archived forum there is a heap of topics and guides to accommodate for the need of using Nvidia for one thing and Intel for another.

1 Like

:+1: Welcome to Manjaro! :+1:

The simple answer is:

In hybrid mode, the Intel is always active unless you activate the more power hungry nVidia driver

There are two ways of doing this:

  1. Start an application with prime-run. E.G.

    prime-run glxinfo 
    prime-run gzdoom VENGNCE.WAD

    will respectively run glxinfo and gzdoom on the nVidia and use the nVidia for those applications only; everything else is still running on the Intel!

  2. Stop using the Hybrid driver and install the nVidia driver only: the nVidia is always active and this is the way I run:

    • Print this page so you have it as a reference while in TTY2

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      sudo mhwd --listinstalled
    • Execute:

      sudo mhwd --remove pci EveryLineFromTheOutputAbove
      sudo mhwd --remove pci OneByOne
    • Now you have no drivers (and why you’re doing this in a TTY) so now install the nVidia proprietary driver:

      sudo mhwd --install pci video-nvidia-440xx
    • And last but not least:

      sudo reboot


1 Like

i ran this and you are right, the opensource driver was blacklisted. thanks for your post, i know now that the proprietary driver is in use now, which means my gaming issues stem from something else.

since the proprietary driver seems to be in use, i agree that dual graphics may be the source of my suffering. ive tried many linux distros on my computer and i always have gpu difficulties. switching to manjaro has mitigated these issues but not removed them. i will look into addressing this issue specifically.

i’m rocking a hybrid driver at the moment, so knowing that the hybrid driver uses intell by default would explain my problems (everything being so smooth and sleek except graphically demanding games). i will take a look into both of your suggestions to address the issue.

for option 2, always having the nvidia gpu active, do you know if this would this make a significant difference in battery life?

What do you want the nvidia card for? If its only gaming you can use lutris to launch all your games and select the option to use prime render offload. This will force all games to run on the nvidia card, you can also enable feral gamemode for better gaming here

1 Like

What is “significant”? I never collected any tangible data but:

  • if I don’t push the nVidia, I cannot see a difference between Intel and nVidia only. (I.E. CPU / GPU usage of 5%)
  • If I do push the nVidia (I.E. gzdoom which also uses quite a lot of CPU) yeah: I’m draining the battery much faster! (About twice as fast, actually)


haha fair point. the language is ambiguous. i was just concerned if i carried my computer to the kitchen it would die after 30 minutes of tv on vlc. sounds like i dont need to be concerned lol. i decided to give you suggestion a try and only use my nvidia gpu. got into tty2 but ran into an issue. when asked for my password, i keep getting “login incorrect”; what password do i need to use for this?

Your normal password but I’ve noticed that if you use Alt Gr special characters the TTY keyboards for some countries are different from the GUI keyboards.

I’ll send you a PM next for this issue.

There some apps to manage battery power, personally I use slimbookbattery, it let you disable a lot of stuff when you don’t needed, managed the cpu governor, etc.

1 Like

gaming. nothing else i do is very graphically demanding. wow, just looked up lutris, sounds fantastic. will definitely give it a try!

1 Like

You are looking for Optimus Manager

After messing around with the drivers over and over, I broke my system and had to reinstall. I decided to try out optimus manager. I installed it along with the qt, so i could manage the app from a tray icon (to avoid messing around with the CLI). Regardless of how many times I logged in and out, it refused to switch to my nvidia GPU, so I changed the settings so on reboot my system would start in nvidia only mode by default. this worked, and in this mode i can use the graphics card. For the first time, i can run my games in manjaro. But of course, nothing ever works correctly on this miserable laptop (rot in hell, asus tuf). When in nvidia only mode, the text size seems to have been shrinked in the system menu and in some apps. Also, my software manager is glitchy and unresponsive. On top of that, I had some issues running commands for some apps in terminal. When i switch back to intell gpu only things go back to normal.

So, I’d be happy to take a look at a video-guide. Clearly this app requires additional configuration on my laptop…

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.